diff options
author | Felix Fietkau <nbd@openwrt.org> | 2007-11-04 11:42:47 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2007-11-04 11:42:47 +0000 |
commit | 5e7effeb4f8c0e507490789961d2a5b23612793e (patch) | |
tree | e6652b80cb564ae311f988cbbb98fecdb4d07905 /Makefile | |
parent | 3131f64f071fd2494958b51df777cdfdd6347b0e (diff) | |
download | upstream-5e7effeb4f8c0e507490789961d2a5b23612793e.tar.gz upstream-5e7effeb4f8c0e507490789961d2a5b23612793e.tar.bz2 upstream-5e7effeb4f8c0e507490789961d2a5b23612793e.zip |
fix parallel build issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9495 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 12 |
1 files changed, 7 insertions, 5 deletions
@@ -9,8 +9,7 @@ TOPDIR:=${CURDIR} LC_ALL:=C LANG:=C -IS_TTY:=${shell tty -s && echo 1 || echo 0} -export TOPDIR LC_ALL LANG IS_TTY +export TOPDIR LC_ALL LANG world: @@ -31,10 +30,13 @@ else include tools/Makefile include toolchain/Makefile -$(toolchain/stamp-compile): $(tools/stamp-compile) +$(toolchain/stamp-install): $(tools/stamp-install) $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared -$(package/stamp-compile): $(target/stamp-compile) -$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) +$(package/stamp-cleanup): $(target/stamp-compile) +$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup) +$(package/stamp-install): $(package/stamp-compile) +$(package/stamp-rootfs-prepare): $(package/stamp-install) +$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(BUILD_DIR)/.prepared: Makefile @mkdir -p $$(dirname $@) |