diff options
author | Christian Marangi <ansuelsmth@gmail.com> | 2022-12-17 16:39:00 +0100 |
---|---|---|
committer | Christian Marangi <ansuelsmth@gmail.com> | 2022-12-18 14:19:07 +0100 |
commit | eb7ffeafbfa78235b05abb4ae479376150d7a814 (patch) | |
tree | 44d5179cab34061d6f96dbcbba7f9f525b9fa066 | |
parent | 47df168dd279d52127f6bbc623e79bdeeb6c8fd4 (diff) | |
download | upstream-eb7ffeafbfa78235b05abb4ae479376150d7a814.tar.gz upstream-eb7ffeafbfa78235b05abb4ae479376150d7a814.tar.bz2 upstream-eb7ffeafbfa78235b05abb4ae479376150d7a814.zip |
rules: fix broken commitcount on alpine system
To generate commitcount we use grep --max-count. This is not present on
alpine grep and cause wrong generation. Use -m as it's just the short
version of --max-count and more portable.
Fixes: #11200
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r-- | rules.mk | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -409,7 +409,7 @@ $(shell \ if git log -1 >/dev/null 2>/dev/null; then \ if [ -n "$(1)" ]; then \ last_bump="$$(git log --pretty=format:'%h %s' . | \ - grep --max-count=1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \ + grep -m 1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \ cut -f 1 -d ' ')"; \ fi; \ if [ -n "$$last_bump" ]; then \ |