diff options
author | Nicolas Thill <nico@openwrt.org> | 2010-01-22 08:12:20 +0000 |
---|---|---|
committer | Nicolas Thill <nico@openwrt.org> | 2010-01-22 08:12:20 +0000 |
commit | 0f3c406bdb09b6fe95487e8924bb26a0358440de (patch) | |
tree | 68a16c147e72fe57d0d22c8f9259a710e9ccbd4d | |
parent | 946291c8d56c01d634c0f032a8fc52b2bf8febf5 (diff) | |
download | upstream-0f3c406bdb09b6fe95487e8924bb26a0358440de.tar.gz upstream-0f3c406bdb09b6fe95487e8924bb26a0358440de.tar.bz2 upstream-0f3c406bdb09b6fe95487e8924bb26a0358440de.zip |
add a config item to specify arguments to strip
SVN-Revision: 19270
-rw-r--r-- | Config.in | 9 | ||||
-rw-r--r-- | rules.mk | 2 |
2 files changed, 10 insertions, 1 deletions
@@ -173,6 +173,15 @@ choice endchoice +config STRIP_ARGS + string + prompt "Strip arguments" + depends USE_STRIP + default "--strip-unneeded --remove-section=.comment --remove-section=.note" if DEBUG + default "--strip-all" + help + Specifies arguments passed to the strip command when stripping binaries + config USE_MKLIBS bool "Strip unnecessary functions from libraries" help @@ -174,7 +174,7 @@ ifneq ($(CONFIG_NO_STRIP),) STRIP:=: else ifneq ($(CONFIG_USE_STRIP),) - STRIP:=$(TARGET_CROSS)strip + STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS)) else ifneq ($(CONFIG_USE_SSTRIP),) STRIP:=$(STAGING_DIR_HOST)/bin/sstrip |