diff options
author | Petr Štetiar <ynezz@true.cz> | 2021-03-03 19:48:55 +0100 |
---|---|---|
committer | Petr Štetiar <ynezz@true.cz> | 2021-03-03 23:03:25 +0100 |
commit | ceb6869cd982056b02f97b51a0e4e2d300ea5b12 (patch) | |
tree | 3cd3d019e88a5c9e2a61af922de056d15e89d814 | |
parent | 27c5db998cba4bc76b5c9dcf71120181cb813886 (diff) | |
download | upstream-ceb6869cd982056b02f97b51a0e4e2d300ea5b12.tar.gz upstream-ceb6869cd982056b02f97b51a0e4e2d300ea5b12.tar.bz2 upstream-ceb6869cd982056b02f97b51a0e4e2d300ea5b12.zip |
build: add which command to build requirements
`which` utility is not shipped by default for example on recent Arch
Linux and then any steps relying on its presence fails, like for example
following Python3 prereq build check:
$ python3 --version
Python 3.9.1
$ make
/bin/sh: line 1: which: command not found
...
Checking 'python3'... failed.
So make `which` utility host build requirement.
References: PR#3820 FS#3525
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 13069b1a1dcbef0bb9b42db98025fa9203283220)
-rw-r--r-- | README.md | 2 | ||||
-rw-r--r-- | include/prereq-build.mk | 3 |
2 files changed, 4 insertions, 1 deletions
@@ -26,7 +26,7 @@ documentation. ``` gcc binutils bzip2 flex python3 perl make find grep diff unzip gawk getopt -subversion libz-dev libc-dev rsync +subversion libz-dev libc-dev rsync which ``` ### Quickstart diff --git a/include/prereq-build.mk b/include/prereq-build.mk index 7c668968b6..86c22f7c95 100644 --- a/include/prereq-build.mk +++ b/include/prereq-build.mk @@ -166,6 +166,9 @@ $(eval $(call SetupHostCommand,file,Please install the 'file' package, \ $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \ rsync --version </dev/null)) +$(eval $(call SetupHostCommand,which,Please install 'which', \ + which which | grep which)) + $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c mkdir -p $(dir $@) $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $< |