diff options
author | Luka Perkov <luka@openwrt.org> | 2013-10-17 15:45:41 +0000 |
---|---|---|
committer | Luka Perkov <luka@openwrt.org> | 2013-10-17 15:45:41 +0000 |
commit | 59eb6137dd51d4cb1215c191230911a092745601 (patch) | |
tree | 0b3a15347d61af21532c9416832abdf49edf0666 | |
parent | 0b57c1ccc6a3112021fc1174ef529ca344b25d9f (diff) | |
download | upstream-59eb6137dd51d4cb1215c191230911a092745601.tar.gz upstream-59eb6137dd51d4cb1215c191230911a092745601.tar.bz2 upstream-59eb6137dd51d4cb1215c191230911a092745601.zip |
build: drop FIT option until we actually need it
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38439
-rw-r--r-- | Config.in | 9 | ||||
-rwxr-xr-x | scripts/metadata.pl | 1 | ||||
-rw-r--r-- | target/Config.in | 3 | ||||
-rw-r--r-- | target/linux/imx6/Makefile | 2 |
4 files changed, 1 insertions, 14 deletions
@@ -189,15 +189,6 @@ menu "Target Images" Include the device tree blob file(s) in the rootfs. Typically the DTBs are placed below /boot. - comment "Image Type" - - config TARGET_IMAGE_FIT - bool "FIT image with kernel and DTB" - default y if USES_FIT - depends on USES_FIT - help - Create a u-boot FIT image containing kernel and DTB - endmenu menu "Global build settings" diff --git a/scripts/metadata.pl b/scripts/metadata.pl index 04fa827c64..ddcf50bf32 100755 --- a/scripts/metadata.pl +++ b/scripts/metadata.pl @@ -172,7 +172,6 @@ sub target_config_features(@) { /targz/ and $ret .= "\tselect USES_TARGZ\n"; /cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n"; /ubifs/ and $ret .= "\tselect USES_UBIFS\n"; - /fit/ and $ret .= "\tselect USES_FIT\n"; /fpu/ and $ret .= "\tselect HAS_FPU\n"; /spe_fpu/ and $ret .= "\tselect HAS_SPE_FPU\n"; /ramdisk/ and $ret .= "\tselect USES_INITRAMFS\n"; diff --git a/target/Config.in b/target/Config.in index 94c10bb34d..7f694e4c8b 100644 --- a/target/Config.in +++ b/target/Config.in @@ -63,9 +63,6 @@ config USES_CPIOGZ config USES_UBIFS bool -config USES_FIT - bool - config PROFILE_KCONFIG bool diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile index ef4f08fa48..4a9bc8cb3c 100644 --- a/target/linux/imx6/Makefile +++ b/target/linux/imx6/Makefile @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk ARCH:=arm BOARD:=imx6 BOARDNAME:=Freescale i.MX 6 Series -FEATURES:=audio display gpio pcie usb usbgadget fit squashfs targz +FEATURES:=audio display gpio pcie usb usbgadget squashfs targz CPU_TYPE:=cortex-a9 CPU_SUBTYPE:=vfpv3 MAINTAINER:=Luka Perkov <luka@openwrt.org> |