aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-19 13:20:41 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-19 13:20:41 +0000
commit29954b9ffcb0022101e70d6a73d090e868e624d7 (patch)
treec9feb47d7c6e14039beff4c7648c90d8a2630adf
parent960002ed4b148cffa7e2562ff4536d3708342765 (diff)
downloadupstream-29954b9ffcb0022101e70d6a73d090e868e624d7.tar.gz
upstream-29954b9ffcb0022101e70d6a73d090e868e624d7.tar.bz2
upstream-29954b9ffcb0022101e70d6a73d090e868e624d7.zip
kernel: remove gpio_buttons
It hasn't been buildable for a long time, and there are no users of it anymore left as all of them have been switched to the upstream accepted version. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37436
-rw-r--r--package/kernel/linux/modules/input.mk18
-rw-r--r--target/linux/generic/files/drivers/input/misc/gpio_buttons.c232
-rw-r--r--target/linux/generic/files/include/linux/gpio_buttons.h33
3 files changed, 0 insertions, 283 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 78fa9241cd..f0bc7bd0ad 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -68,24 +68,6 @@ endef
$(eval $(call KernelPackage,input-evdev))
-define KernelPackage/input-gpio-buttons
- SUBMENU:=$(INPUT_MODULES_MENU)
- TITLE:=Polled GPIO buttons input device
- DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
- KCONFIG:= \
- CONFIG_INPUT_GPIO_BUTTONS \
- CONFIG_INPUT_MISC=y
- FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
- AUTOLOAD:=$(call AutoLoad,62,gpio_buttons,1)
-endef
-
-define KernelPackage/input-gpio-buttons/description
- Kernel module for support polled GPIO buttons input device
-endef
-
-$(eval $(call KernelPackage,input-gpio-buttons))
-
-
define KernelPackage/input-gpio-keys
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=GPIO key support
diff --git a/target/linux/generic/files/drivers/input/misc/gpio_buttons.c b/target/linux/generic/files/drivers/input/misc/gpio_buttons.c
deleted file mode 100644
index af54914342..0000000000
--- a/target/linux/generic/files/drivers/input/misc/gpio_buttons.c
+++ /dev/null
@@ -1,232 +0,0 @@
-/*
- * Driver for buttons on GPIO lines not capable of generating interrupts
- *
- * Copyright (C) 2007-2010 Gabor Juhos <juhosg@openwrt.org>
- * Copyright (C) 2010 Nuno Goncalves <nunojpg@gmail.com>
- *
- * This file was based on: /drivers/input/misc/cobalt_btns.c
- * Copyright (C) 2007 Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
- *
- * also was based on: /drivers/input/keyboard/gpio_keys.c
- * Copyright 2005 Phil Blundell
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- */
-
-#include <linux/kernel.h>
-#include <linux/module.h>
-#include <linux/init.h>
-#include <linux/slab.h>
-#include <linux/input.h>
-#include <linux/input-polldev.h>
-#include <linux/ioport.h>
-#include <linux/platform_device.h>
-#include <linux/gpio.h>
-#include <linux/gpio_buttons.h>
-
-#define DRV_NAME "gpio-buttons"
-
-struct gpio_button_data {
- int last_state;
- int count;
- int can_sleep;
-};
-
-struct gpio_buttons_dev {
- struct input_polled_dev *poll_dev;
- struct gpio_buttons_platform_data *pdata;
- struct gpio_button_data *data;
-};
-
-static void gpio_buttons_check_state(struct input_dev *input,
- struct gpio_button *button,
- struct gpio_button_data *bdata)
-{
- int state;
-
- if (bdata->can_sleep)
- state = !!gpio_get_value_cansleep(button->gpio);
- else
- state = !!gpio_get_value(button->gpio);
-
- if (state != bdata->last_state) {
- unsigned int type = button->type ?: EV_KEY;
-
- input_event(input, type, button->code,
- !!(state ^ button->active_low));
- input_sync(input);
- bdata->count = 0;
- bdata->last_state = state;
- }
-}
-
-static void gpio_buttons_poll(struct input_polled_dev *dev)
-{
- struct gpio_buttons_dev *bdev = dev->private;
- struct gpio_buttons_platform_data *pdata = bdev->pdata;
- struct input_dev *input = dev->input;
- int i;
-
- for (i = 0; i < bdev->pdata->nbuttons; i++) {
- struct gpio_button *button = &pdata->buttons[i];
- struct gpio_button_data *bdata = &bdev->data[i];
-
- if (bdata->count < button->threshold)
- bdata->count++;
- else
- gpio_buttons_check_state(input, button, bdata);
-
- }
-}
-
-static int gpio_buttons_probe(struct platform_device *pdev)
-{
- struct gpio_buttons_platform_data *pdata = pdev->dev.platform_data;
- struct device *dev = &pdev->dev;
- struct gpio_buttons_dev *bdev;
- struct input_polled_dev *poll_dev;
- struct input_dev *input;
- int error;
- int i;
-
- if (!pdata)
- return -ENXIO;
-
- bdev = kzalloc(sizeof(struct gpio_buttons_dev) +
- pdata->nbuttons * sizeof(struct gpio_button_data),
- GFP_KERNEL);
- if (!bdev) {
- dev_err(dev, "no memory for private data\n");
- return -ENOMEM;
- }
-
- bdev->data = (struct gpio_button_data *) &bdev[1];
-
- poll_dev = input_allocate_polled_device();
- if (!poll_dev) {
- dev_err(dev, "no memory for polled device\n");
- error = -ENOMEM;
- goto err_free_bdev;
- }
-
- poll_dev->private = bdev;
- poll_dev->poll = gpio_buttons_poll;
- poll_dev->poll_interval = pdata->poll_interval;
-
- input = poll_dev->input;
-
- input->evbit[0] = BIT(EV_KEY);
- input->name = pdev->name;
- input->phys = "gpio-buttons/input0";
- input->dev.parent = &pdev->dev;
-
- input->id.bustype = BUS_HOST;
- input->id.vendor = 0x0001;
- input->id.product = 0x0001;
- input->id.version = 0x0100;
-
- for (i = 0; i < pdata->nbuttons; i++) {
- struct gpio_button *button = &pdata->buttons[i];
- unsigned int gpio = button->gpio;
- unsigned int type = button->type ?: EV_KEY;
-
- error = gpio_request(gpio,
- button->desc ? button->desc : DRV_NAME);
- if (error) {
- dev_err(dev, "unable to claim gpio %u, err=%d\n",
- gpio, error);
- goto err_free_gpio;
- }
-
- error = gpio_direction_input(gpio);
- if (error) {
- dev_err(dev,
- "unable to set direction on gpio %u, err=%d\n",
- gpio, error);
- goto err_free_gpio;
- }
-
- bdev->data[i].can_sleep = gpio_cansleep(gpio);
- bdev->data[i].last_state = -1;
-
- input_set_capability(input, type, button->code);
- }
-
- bdev->poll_dev = poll_dev;
- bdev->pdata = pdata;
- platform_set_drvdata(pdev, bdev);
-
- error = input_register_polled_device(poll_dev);
- if (error) {
- dev_err(dev, "unable to register polled device, err=%d\n",
- error);
- goto err_free_gpio;
- }
-
- /* report initial state of the buttons */
- for (i = 0; i < pdata->nbuttons; i++)
- gpio_buttons_check_state(input, &pdata->buttons[i],
- &bdev->data[i]);
-
- return 0;
-
-err_free_gpio:
- for (i = i - 1; i >= 0; i--)
- gpio_free(pdata->buttons[i].gpio);
-
- input_free_polled_device(poll_dev);
-
-err_free_bdev:
- kfree(bdev);
-
- platform_set_drvdata(pdev, NULL);
- return error;
-}
-
-static int gpio_buttons_remove(struct platform_device *pdev)
-{
- struct gpio_buttons_dev *bdev = platform_get_drvdata(pdev);
- struct gpio_buttons_platform_data *pdata = bdev->pdata;
- int i;
-
- input_unregister_polled_device(bdev->poll_dev);
-
- for (i = 0; i < pdata->nbuttons; i++)
- gpio_free(pdata->buttons[i].gpio);
-
- input_free_polled_device(bdev->poll_dev);
-
- kfree(bdev);
- platform_set_drvdata(pdev, NULL);
-
- return 0;
-}
-
-static struct platform_driver gpio_buttons_driver = {
- .probe = gpio_buttons_probe,
- .remove = gpio_buttons_remove,
- .driver = {
- .name = DRV_NAME,
- .owner = THIS_MODULE,
- },
-};
-
-static int __init gpio_buttons_init(void)
-{
- return platform_driver_register(&gpio_buttons_driver);
-}
-
-static void __exit gpio_buttons_exit(void)
-{
- platform_driver_unregister(&gpio_buttons_driver);
-}
-
-module_init(gpio_buttons_init);
-module_exit(gpio_buttons_exit);
-
-MODULE_LICENSE("GPL v2");
-MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org>");
-MODULE_DESCRIPTION("Polled GPIO Buttons driver");
diff --git a/target/linux/generic/files/include/linux/gpio_buttons.h b/target/linux/generic/files/include/linux/gpio_buttons.h
deleted file mode 100644
index f85b993ed2..0000000000
--- a/target/linux/generic/files/include/linux/gpio_buttons.h
+++ /dev/null
@@ -1,33 +0,0 @@
-/*
- * Definitions for the GPIO buttons interface driver
- *
- * Copyright (C) 2007-2010 Gabor Juhos <juhosg@openwrt.org>
- *
- * This file was based on: /include/linux/gpio_keys.h
- * The original gpio_keys.h seems not to have a license.
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- */
-
-#ifndef _GPIO_BUTTONS_H_
-#define _GPIO_BUTTONS_H_
-
-struct gpio_button {
- int gpio; /* GPIO line number */
- int active_low;
- char *desc; /* button description */
- int type; /* input event type (EV_KEY, EV_SW) */
- int code; /* input event code (KEY_*, SW_*) */
- int threshold; /* count threshold */
-};
-
-struct gpio_buttons_platform_data {
- struct gpio_button *buttons;
- int nbuttons; /* number of buttons */
- int poll_interval; /* polling interval */
-};
-
-#endif /* _GPIO_BUTTONS_H_ */
' href='#n648'>648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826 827 828 829 830 831 832 833 834 835 836 837 838 839 840 841 842 843 844 845 846 847 848 849 850 851 852 853 854 855 856 857 858 859 860 861 862 863 864 865 866 867 868 869 870 871 872 873 874 875 876 877 878 879 880 881 882 883 884 885 886 887 888 889 890 891 892 893 894 895 896 897 898 899 900 901 902 903 904 905 906 907 908 909 910 911 912 913 914 915 916 917 918 919 920 921 922 923 924 925 926 927 928 929 930 931 932 933 934 935 936 937 938 939 940 941 942 943 944 945 946 947 948 949 950 951 952 953 954 955 956 957 958 959 960 961 962 963 964 965 966 967 968 969 970 971 972 973 974 975 976 977 978 979 980 981 982 983 984 985 986 987 988 989 990 991 992 993 994 995 996 997 998 999 1000 1001 1002 1003 1004 1005 1006 1007 1008 1009 1010 1011 1012 1013 1014 1015 1016 1017 1018 1019 1020 1021 1022 1023 1024 1025 1026 1027 1028 1029 1030 1031 1032 1033 1034 1035 1036 1037 1038 1039 1040 1041 1042 1043 1044 1045 1046 1047 1048 1049 1050 1051 1052 1053 1054 1055 1056 1057 1058 1059 1060 1061 1062 1063 1064 1065 1066 1067 1068 1069 1070 1071 1072 1073 1074 1075 1076 1077 1078 1079 1080 1081 1082 1083 1084 1085 1086 1087 1088 1089 1090 1091 1092 1093 1094 1095 1096 1097 1098 1099 1100 1101 1102 1103 1104 1105 1106 1107 1108 1109 1110 1111 1112 1113 1114 1115 1116 1117 1118 1119 1120 1121 1122 1123 1124 1125 1126 1127 1128