diff options
author | Felix Fietkau <nbd@openwrt.org> | 2010-02-24 23:43:05 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2010-02-24 23:43:05 +0000 |
commit | 15fecc9e6c2df765a148b3ceee46c4dbb12e1392 (patch) | |
tree | baed0f5be3ecc303950aa5b17d578f53f5d1f936 | |
parent | 001736d84888e2fc0c682c6cb36a4ec6fb9096f6 (diff) | |
download | upstream-15fecc9e6c2df765a148b3ceee46c4dbb12e1392.tar.gz upstream-15fecc9e6c2df765a148b3ceee46c4dbb12e1392.tar.bz2 upstream-15fecc9e6c2df765a148b3ceee46c4dbb12e1392.zip |
remove support for DEBUG_DIR, it has lost its purpose since STAGING_DIR_ROOT was added
SVN-Revision: 19849
-rw-r--r-- | Config.in | 7 | ||||
-rw-r--r-- | include/package-debug.mk | 26 | ||||
-rw-r--r-- | include/package.mk | 3 | ||||
-rw-r--r-- | rules.mk | 1 |
4 files changed, 1 insertions, 36 deletions
@@ -206,13 +206,6 @@ config DEBUG help Adds -g3 to the CFLAGS -config DEBUG_DIR - bool "Install debugging binaries into a staging directory" - default n - help - This will install all compiled package binaries into build_dir/target-*/debug-*/, - useful for cross-debugging via gdb/gdbserver - config IPV6 bool prompt "Enable IPv6 support in packages" diff --git a/include/package-debug.mk b/include/package-debug.mk deleted file mode 100644 index 2a85bfebb8..0000000000 --- a/include/package-debug.mk +++ /dev/null @@ -1,26 +0,0 @@ -# -# Copyright (C) 2006,2007 OpenWrt.org -# -# This is free software, licensed under the GNU General Public License v2. -# See /LICENSE for more information. -# - -ifeq ($(DUMP),) - define BuildTarget/debug - - DEBUG_STAMP_$(1) := $(DEBUG_DIR)/stamp/$(1) - - ifdef Package/$(1)/install - ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),) - compile: $$(DEBUG_STAMP_$(1)) - endif - endif - - $$(DEBUG_STAMP_$(1)): $(PKG_BUILD_DIR)/.built - mkdir -p $(DEBUG_DIR)/stamp - $(call Package/$(1)/install,$(DEBUG_DIR)) - touch $$(DEBUG_STAMP_$(1)) - - - endef -endif diff --git a/include/package.mk b/include/package.mk index 90aa51c595..f48c790575 100644 --- a/include/package.mk +++ b/include/package.mk @@ -26,7 +26,6 @@ include $(INCLUDE_DIR)/quilt.mk include $(INCLUDE_DIR)/package-defaults.mk include $(INCLUDE_DIR)/package-dumpinfo.mk include $(INCLUDE_DIR)/package-ipkg.mk -include $(INCLUDE_DIR)/package-debug.mk include $(INCLUDE_DIR)/package-bin.mk include $(INCLUDE_DIR)/autotools.mk @@ -179,7 +178,7 @@ endif $(Dumpinfo/Package), \ $(foreach target, \ $(if $(Package/$(1)/targets),$(Package/$(1)/targets), \ - $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg $(if $(CONFIG_DEBUG_DIR),debug)) \ + $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg) \ ), $(BuildTarget/$(target)) \ ) \ ) @@ -80,7 +80,6 @@ STAMP_DIR_HOST=$(BUILD_DIR_HOST)/stamp TARGET_ROOTFS_DIR?=$(if $(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(BUILD_DIR)) TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD) STAGING_DIR_ROOT:=$(STAGING_DIR)/root-$(BOARD) -DEBUG_DIR:=$(BUILD_DIR)/debug-$(BOARD) BUILD_LOG_DIR:=$(TOPDIR)/logs TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(PATH) |