aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-28 00:06:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-28 00:06:37 +0000
commit295d0a7e82f5b8deb238c34a9d5291f9b71c690a (patch)
tree713ea38ad32e43285a1174b4b26430d2aab5f025
parent89b89ef77d578ed227fe0c127c9e332eafaf9f78 (diff)
downloadupstream-295d0a7e82f5b8deb238c34a9d5291f9b71c690a.tar.gz
upstream-295d0a7e82f5b8deb238c34a9d5291f9b71c690a.tar.bz2
upstream-295d0a7e82f5b8deb238c34a9d5291f9b71c690a.zip
allow the user to change the rb532 rootfs size in menuconfig (fixes #1374)
SVN-Revision: 6417
-rw-r--r--Config.in4
-rw-r--r--target/linux/rb532-2.6/image/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/Config.in b/Config.in
index 0b6fa95927..cdc7b6e2dd 100644
--- a/Config.in
+++ b/Config.in
@@ -109,14 +109,14 @@ source "target/linux/*/image/Config.in"
config TARGET_ROOTFS_FSPART
int "Filesystem part size (in MB)"
- depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+ depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS || LINUX_2_6_RB532
default 16
help
Allows you to change the filesystem partition size
config TARGET_ROOTFS_MAXINODE
int "Maximum number of inodes in filesystem"
- depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+ depends TARGET_ROOTFS_EXT2FS
default 1500
help
Allows you to change the maximum number of inodes in the filesystem
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 2ded1c0788..b35b0b1e7b 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -52,7 +52,7 @@ endef
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
- ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf 16 $(KDIR)/root.$(1)
+ ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
$(eval $(call BuildImage))
='#n219'>219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489
# Keycodes Overview

When defining a [keymap](keymap.md) each key needs a valid key definition. This page documents the symbols that correspond to keycodes that are available to you in QMK.

This is a reference only. Each group of keys links to the page documenting their functionality in more detail.

## [Basic Keycodes](keycodes_basic.md)

|Key                    |Aliases                       |Description                                    |
|-----------------------|------------------------------|-----------------------------------------------|
|`KC_NO`                |`XXXXXXX`                     |Ignore this key (NOOP)                         |
|`KC_TRANSPARENT`       |`KC_TRNS`, `_______`          |Use the next lowest non-transparent key        |
|`KC_A`                 |                              |`a` and `A`                                    |
|`KC_B`                 |                              |`b` and `B`                                    |
|`KC_C`                 |                              |`c` and `C`                                    |
|`KC_D`                 |                              |`d` and `D`                                    |
|`KC_E`                 |                              |`e` and `E`                                    |
|`KC_F`                 |                              |`f` and `F`                                    |
|`KC_G`                 |                              |`g` and `G`                                    |
|`KC_H`                 |                              |`h` and `H`                                    |
|`KC_I`                 |                              |`i` and `I`                                    |
|`KC_J`                 |                              |`j` and `J`                                    |
|`KC_K`                 |                              |`k` and `K`                                    |
|`KC_L`                 |                              |`l` and `L`                                    |
|`KC_M`                 |                              |`m` and `M`                                    |
|`KC_N`                 |                              |`n` and `N`                                    |
|`KC_O`                 |                              |`o` and `O`                                    |
|`KC_P`                 |                              |`p` and `P`                                    |
|`KC_Q`                 |                              |`q` and `Q`                                    |
|`KC_R`                 |                              |`r` and `R`                                    |
|`KC_S`                 |                              |`s` and `S`                                    |
|`KC_T`                 |                              |`t` and `T`                                    |
|`KC_U`                 |                              |`u` and `U`                                    |
|`KC_V`                 |                              |`v` and `V`                                    |
|`KC_W`                 |                              |`w` and `W`                                    |
|`KC_X`                 |                              |`x` and `X`                                    |
|`KC_Y`                 |                              |`y` and `Y`                                    |
|`KC_Z`                 |                              |`z` and `Z`                                    |
|`KC_1`                 |                              |`1` and `!`                                    |
|`KC_2`                 |                              |`2` and `@`                                    |
|`KC_3`                 |                              |`3` and `#`                                    |
|`KC_4`                 |                              |`4` and `$`                                    |
|`KC_5`                 |                              |`5` and `%`                                    |
|`KC_6`                 |                              |`6` and `^`                                    |
|`KC_7`                 |                              |`7` and `&`                                    |
|`KC_8`                 |                              |`8` and `*`                                    |
|`KC_9`                 |                              |`9` and `(`                                    |
|`KC_0`                 |                              |`0` and `)`                                    |
|`KC_ENTER`             |`KC_ENT`                      |Return (Enter)                                 |
|`KC_ESCAPE`            |`KC_ESC`                      |Escape                                         |
|`KC_BSPACE`            |`KC_BSPC`                     |Delete (Backspace)                             |
|`KC_TAB`               |                              |Tab                                            |
|`KC_SPACE`             |`KC_SPC`                      |Spacebar                                       |
|`KC_MINUS`             |`KC_MINS`                     |`-` and `_`                                    |
|`KC_EQUAL`             |`KC_EQL`                      |`=` and `+`                                    |
|`KC_LBRACKET`          |`KC_LBRC`                     |`[` and `{`                                    |
|`KC_RBRACKET`          |`KC_RBRC`                     |`]` and `}`                                    |
|`KC_BSLASH`            |`KC_BSLS`                     |`\` and `\|`                                   |
|`KC_NONUS_HASH`        |`KC_NUHS`                     |Non-US `#` and `~`                             |
|`KC_SCOLON`            |`KC_SCLN`                     |`;` and `:`                                    |
|`KC_QUOTE`             |`KC_QUOT`                     |`'` and `"`                                    |
|`KC_GRAVE`             |`KC_GRV`, `KC_ZKHK`           |<code>&#96;</code> and `~`, JIS Zenkaku/Hankaku|
|`KC_COMMA`             |`KC_COMM`                     |`,` and `<`                                    |
|`KC_DOT`               |                              |`.` and `>`                                    |
|`KC_SLASH`             |`KC_SLSH`                     |`/` and `?`                                    |
|`KC_CAPSLOCK`          |`KC_CLCK`, `KC_CAPS`          |Caps Lock                                      |
|`KC_F1`                |                              |F1                                             |
|`KC_F2`                |                              |F2                                             |
|`KC_F3`                |                              |F3                                             |
|`KC_F4`                |                              |F4                                             |
|`KC_F5`                |                              |F5                                             |