From 716ca530e1c4515d8683c9d5be3d56b301758b66 Mon Sep 17 00:00:00 2001
From: James <>
Date: Wed, 4 Nov 2015 11:49:21 +0000
Subject: trunk-47381

---
 tools/automake/Makefile                            | 50 +++++++++++
 tools/automake/files/aclocal                       |  2 +
 tools/automake/patches/000-relocatable.patch       | 96 ++++++++++++++++++++++
 ...100-aclocal-skip-not-existing-directories.patch | 15 ++++
 .../patches/200-do-not-override-silent-rules.patch | 13 +++
 5 files changed, 176 insertions(+)
 create mode 100644 tools/automake/Makefile
 create mode 100755 tools/automake/files/aclocal
 create mode 100644 tools/automake/patches/000-relocatable.patch
 create mode 100644 tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
 create mode 100644 tools/automake/patches/200-do-not-override-silent-rules.patch

(limited to 'tools/automake')

diff --git a/tools/automake/Makefile b/tools/automake/Makefile
new file mode 100644
index 0000000..0eea101
--- /dev/null
+++ b/tools/automake/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=automake
+PKG_VERSION:=1.15
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/automake
+PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+	--datarootdir=$(STAGING_DIR_HOST)/share \
+	--disable-silent-rules
+
+HOST_CONFIGURE_VARS += \
+	PERL="/usr/bin/env perl" \
+	am_cv_prog_PERL_ithreads=no
+
+define Host/Configure
+	(cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+	$(call Host/Configure/Default)
+endef
+
+define Host/Install
+	# remove old automake resources to avoid version conflicts
+	rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+	rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
+	$(MAKE) -C $(HOST_BUILD_DIR) install
+	mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
+	$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
+	ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+	ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
+	ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
+	ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
+	ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
+endef
+
+define Host/Clean
+	-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+	$(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/automake/files/aclocal b/tools/automake/files/aclocal
new file mode 100755
index 0000000..a60df10
--- /dev/null
+++ b/tools/automake/files/aclocal
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+aclocal.real $ACLOCAL_INCLUDE $@
diff --git a/tools/automake/patches/000-relocatable.patch b/tools/automake/patches/000-relocatable.patch
new file mode 100644
index 0000000..59864f2
--- /dev/null
+++ b/tools/automake/patches/000-relocatable.patch
@@ -0,0 +1,96 @@
+--- a/lib/Automake/Config.in
++++ b/lib/Automake/Config.in
+@@ -32,7 +32,7 @@ our $PACKAGE = '@PACKAGE@';
+ our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
+ our $VERSION = '@VERSION@';
+ our $RELEASE_YEAR = '@RELEASE_YEAR@';
+-our $libdir = '@datadir@/@PACKAGE@-@APIVERSION@';
++our $libdir = $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@';
+ 
+ our $perl_threads = 0;
+ # We need at least this version for CLONE support.
+--- a/bin/aclocal.in
++++ b/bin/aclocal.in
+@@ -1,10 +1,12 @@
+-#!@PERL@ -w
++#!@PERL@
+ # -*- perl -*-
+ # @configure_input@
+ 
+ eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+     if 0;
+ 
++$^W = 1;
++
+ # aclocal - create aclocal.m4 by scanning configure.ac
+ 
+ # Copyright (C) 1996-2014 Free Software Foundation, Inc.
+@@ -27,7 +29,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
+ 
+ BEGIN
+ {
+-  @Aclocal::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
++  @Aclocal::perl_libdirs = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
+     unless @Aclocal::perl_libdirs;
+   unshift @INC, @Aclocal::perl_libdirs;
+ }
+@@ -69,8 +71,8 @@ $perl_threads = 0;
+ # ACLOCAL_PATH environment variable, and reset with the '--system-acdir'
+ # option.
+ my @user_includes = ();
+-my @automake_includes = ("@datadir@/aclocal-$APIVERSION");
+-my @system_includes = ('@datadir@/aclocal');
++my @automake_includes = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . "/../host/share/aclocal-$APIVERSION" : "@datadir@/aclocal-$APIVERSION");
++my @system_includes = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/aclocal' : '@datadir@/aclocal');
+ 
+ # Whether we should copy M4 file in $user_includes[0].
+ my $install = 0;
+--- a/bin/automake.in
++++ b/bin/automake.in
+@@ -1,10 +1,12 @@
+-#!@PERL@ -w
++#!@PERL@
+ # -*- perl -*-
+ # @configure_input@
+ 
+ eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+     if 0;
+ 
++$^W = 1;
++
+ # automake - create Makefile.in from Makefile.am
+ # Copyright (C) 1994-2014 Free Software Foundation, Inc.
+ 
+@@ -31,7 +33,7 @@ use strict;
+ 
+ BEGIN
+ {
+-  @Automake::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
++  @Automake::perl_libdirs = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
+     unless @Automake::perl_libdirs;
+   unshift @INC, @Automake::perl_libdirs;
+ 
+--- a/t/wrap/aclocal.in
++++ b/t/wrap/aclocal.in
+@@ -1,6 +1,8 @@
+-#!@PERL@ -w
++#!@PERL@
+ # @configure_input@
+ 
++$^W = 1;
++
+ # Copyright (C) 2012-2014 Free Software Foundation, Inc.
+ 
+ # This program is free software; you can redistribute it and/or modify
+--- a/t/wrap/automake.in
++++ b/t/wrap/automake.in
+@@ -1,6 +1,8 @@
+-#!@PERL@ -w
++#!@PERL@
+ # @configure_input@
+ 
++$^W = 1;
++
+ # Copyright (C) 2012-2014 Free Software Foundation, Inc.
+ 
+ # This program is free software; you can redistribute it and/or modify
diff --git a/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch b/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
new file mode 100644
index 0000000..ad019dd
--- /dev/null
+++ b/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
@@ -0,0 +1,15 @@
+--- a/bin/aclocal.in
++++ b/bin/aclocal.in
+@@ -356,6 +356,12 @@ sub scan_m4_dirs ($$@)
+ 
+   foreach my $m4dir (@dirlist)
+     {
++      if (! -d $m4dir)
++        {
++          msg ('override', "warning: skipping not existing directory `$m4dir'");
++          next;
++        }
++
+       if (! opendir (DIR, $m4dir))
+ 	{
+ 	  # TODO: maybe avoid complaining only if errno == ENONENT?
diff --git a/tools/automake/patches/200-do-not-override-silent-rules.patch b/tools/automake/patches/200-do-not-override-silent-rules.patch
new file mode 100644
index 0000000..e8ba8c5
--- /dev/null
+++ b/tools/automake/patches/200-do-not-override-silent-rules.patch
@@ -0,0 +1,13 @@
+diff -ruN automake-1.15/m4/silent.m4 automake-1.15.mod/m4/silent.m4
+--- automake-1.15/m4/silent.m4	2014-12-30 22:53:05.000000000 +0100
++++ automake-1.15.mod/m4/silent.m4	2015-03-11 12:00:26.280586399 +0100
+@@ -41,7 +41,8 @@
+ else
+   am_cv_make_support_nested_variables=no
+ fi])
+-if test $am_cv_make_support_nested_variables = yes; then
++#if test $am_cv_make_support_nested_variables = yes; then
++if false; then
+   dnl Using '$V' instead of '$(V)' breaks IRIX make.
+   AM_V='$(V)'
+   AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
-- 
cgit v1.2.3