From 89563cf12af18c86e47069dc313b4cdc9c1f1a5a Mon Sep 17 00:00:00 2001
From: "Alexandros C. Couloumbis" <alex@ozo.com>
Date: Tue, 23 Nov 2010 14:04:42 +0000
Subject: linux/generic: refresh 2.6.37 patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24111 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/generic/patches-2.6.37/100-netfilter_layer7_2.22.patch | 6 +++---
 .../generic/patches-2.6.37/103-netfilter_layer7_2.6.36_fix.patch    | 4 ++--
 target/linux/generic/patches-2.6.37/180-netfilter_depends.patch     | 2 +-
 target/linux/generic/patches-2.6.37/240-packet_socket_type.patch    | 4 ++--
 target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch         | 4 ++--
 target/linux/generic/patches-2.6.37/402-ledtrig_netdev.patch        | 4 ++--
 target/linux/generic/patches-2.6.37/420-gpiodev.patch               | 2 +-
 .../linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch | 6 +++---
 .../linux/generic/patches-2.6.37/840-unable_to_open_console.patch   | 2 +-
 target/linux/generic/patches-2.6.37/922-gpiommc.patch               | 2 +-
 target/linux/generic/patches-2.6.37/980-vm_exports.patch            | 6 +++---
 target/linux/generic/patches-2.6.37/999-use_preinit_as_init.patch   | 2 +-
 12 files changed, 22 insertions(+), 22 deletions(-)

(limited to 'target')

diff --git a/target/linux/generic/patches-2.6.37/100-netfilter_layer7_2.22.patch b/target/linux/generic/patches-2.6.37/100-netfilter_layer7_2.22.patch
index 4d969e290b..88b656b5e4 100644
--- a/target/linux/generic/patches-2.6.37/100-netfilter_layer7_2.22.patch
+++ b/target/linux/generic/patches-2.6.37/100-netfilter_layer7_2.22.patch
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -946,6 +946,27 @@ config NETFILTER_XT_MATCH_STATE
+@@ -948,6 +948,27 @@ config NETFILTER_XT_MATCH_STATE
  
  	  To compile it as a module, choose M here.  If unsure, say N.
  
@@ -2059,7 +2059,7 @@
 +}
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -202,6 +202,14 @@ destroy_conntrack(struct nf_conntrack *n
+@@ -212,6 +212,14 @@ destroy_conntrack(struct nf_conntrack *n
  	 * too. */
  	nf_ct_remove_expectations(ct);
  
@@ -2076,7 +2076,7 @@
  		BUG_ON(hlist_nulls_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnnode));
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -178,6 +178,12 @@ static int ct_seq_show(struct seq_file *
+@@ -200,6 +200,12 @@ static int ct_seq_show(struct seq_file *
  		goto release;
  #endif
  
diff --git a/target/linux/generic/patches-2.6.37/103-netfilter_layer7_2.6.36_fix.patch b/target/linux/generic/patches-2.6.37/103-netfilter_layer7_2.6.36_fix.patch
index e9aa3c967f..1082da5b67 100644
--- a/target/linux/generic/patches-2.6.37/103-netfilter_layer7_2.6.36_fix.patch
+++ b/target/linux/generic/patches-2.6.37/103-netfilter_layer7_2.6.36_fix.patch
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -781,6 +781,27 @@ config NETFILTER_XT_MATCH_IPVS
+@@ -762,6 +762,27 @@ config NETFILTER_XT_MATCH_IPVS
  
  	  If unsure, say N.
  
@@ -28,7 +28,7 @@
  config NETFILTER_XT_MATCH_LENGTH
  	tristate '"length" match support'
  	depends on NETFILTER_ADVANCED
-@@ -966,26 +987,11 @@ config NETFILTER_XT_MATCH_STATE
+@@ -948,26 +969,11 @@ config NETFILTER_XT_MATCH_STATE
  
  	  To compile it as a module, choose M here.  If unsure, say N.
  
diff --git a/target/linux/generic/patches-2.6.37/180-netfilter_depends.patch b/target/linux/generic/patches-2.6.37/180-netfilter_depends.patch
index d270e9020b..22bf51c3a9 100644
--- a/target/linux/generic/patches-2.6.37/180-netfilter_depends.patch
+++ b/target/linux/generic/patches-2.6.37/180-netfilter_depends.patch
@@ -8,7 +8,7 @@
  	depends on NETFILTER_ADVANCED
  	help
  	  H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -558,7 +557,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -570,7 +569,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
  	tristate '"TCPMSS" target support'
diff --git a/target/linux/generic/patches-2.6.37/240-packet_socket_type.patch b/target/linux/generic/patches-2.6.37/240-packet_socket_type.patch
index 204512ff11..f5cb465e93 100644
--- a/target/linux/generic/patches-2.6.37/240-packet_socket_type.patch
+++ b/target/linux/generic/patches-2.6.37/240-packet_socket_type.patch
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
  	if (sock->type == SOCK_PACKET)
  		po->prot_hook.func = packet_rcv_spkt;
-@@ -2054,6 +2058,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2057,6 +2061,16 @@ packet_setsockopt(struct socket *sock, i
  		po->tp_tstamp = val;
  		return 0;
  	}
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  	default:
  		return -ENOPROTOOPT;
  	}
-@@ -2111,6 +2125,13 @@ static int packet_getsockopt(struct sock
+@@ -2114,6 +2128,13 @@ static int packet_getsockopt(struct sock
  
  		data = &val;
  		break;
diff --git a/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
index 60a9f38903..3252cd5b85 100644
--- a/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
+++ b/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -389,4 +389,8 @@ endif # LEDS_TRIGGERS
+@@ -407,4 +407,8 @@ endif # LEDS_TRIGGERS
  
  endif # LEDS_CLASS
  
@@ -11,7 +11,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -50,3 +50,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)	+=
+@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)	+=
  obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)	+= ledtrig-backlight.o
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)		+= ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON)	+= ledtrig-default-on.o
diff --git a/target/linux/generic/patches-2.6.37/402-ledtrig_netdev.patch b/target/linux/generic/patches-2.6.37/402-ledtrig_netdev.patch
index 8c6fb17d8f..7f559e19e5 100644
--- a/target/linux/generic/patches-2.6.37/402-ledtrig_netdev.patch
+++ b/target/linux/generic/patches-2.6.37/402-ledtrig_netdev.patch
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -393,4 +393,11 @@ config LEDS_TRIGGER_MORSE
+@@ -411,4 +411,11 @@ config LEDS_TRIGGER_MORSE
  	tristate "LED Morse Trigger"
  	depends on LEDS_TRIGGERS
  
@@ -14,7 +14,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)	+=
+@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)	+=
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)		+= ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON)	+= ledtrig-default-on.o
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)	+= ledtrig-morse.o
diff --git a/target/linux/generic/patches-2.6.37/420-gpiodev.patch b/target/linux/generic/patches-2.6.37/420-gpiodev.patch
index 0915799bc7..690b5e6cd8 100644
--- a/target/linux/generic/patches-2.6.37/420-gpiodev.patch
+++ b/target/linux/generic/patches-2.6.37/420-gpiodev.patch
@@ -17,7 +17,7 @@
  	depends on BLOCK
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -99,6 +99,7 @@ obj-$(CONFIG_SCx200_GPIO)	+= scx200_gpio
+@@ -82,6 +82,7 @@ obj-$(CONFIG_SCx200_GPIO)	+= scx200_gpio
  obj-$(CONFIG_PC8736x_GPIO)	+= pc8736x_gpio.o
  obj-$(CONFIG_NSC_GPIO)		+= nsc_gpio.o
  obj-$(CONFIG_CS5535_GPIO)	+= cs5535_gpio.o
diff --git a/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch b/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
index 79c587c1ef..aa64c686f3 100644
--- a/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
+++ b/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
@@ -1,6 +1,6 @@
 --- a/drivers/usb/serial/usb-serial.c
 +++ b/drivers/usb/serial/usb-serial.c
-@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
+@@ -60,6 +60,7 @@ static struct usb_driver usb_serial_driv
     drivers depend on it.
  */
  
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -912,7 +913,7 @@ int usb_serial_probe(struct usb_interfac
  		}
  		buffer_size = serial->type->bulk_in_size;
  		if (!buffer_size)
@@ -17,7 +17,7 @@
  		port->bulk_in_size = buffer_size;
  		port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
  		port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1386,3 +1387,5 @@ MODULE_LICENSE("GPL");
+@@ -1385,3 +1386,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
diff --git a/target/linux/generic/patches-2.6.37/840-unable_to_open_console.patch b/target/linux/generic/patches-2.6.37/840-unable_to_open_console.patch
index bfb4e0d165..8f1a4cb8ed 100644
--- a/target/linux/generic/patches-2.6.37/840-unable_to_open_console.patch
+++ b/target/linux/generic/patches-2.6.37/840-unable_to_open_console.patch
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -891,7 +891,7 @@ static int __init kernel_init(void * unu
+@@ -890,7 +890,7 @@ static int __init kernel_init(void * unu
  
  	/* Open the /dev/console on the rootfs, this should never fail */
  	if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
diff --git a/target/linux/generic/patches-2.6.37/922-gpiommc.patch b/target/linux/generic/patches-2.6.37/922-gpiommc.patch
index 5cdb1318bb..8eb66e4563 100644
--- a/target/linux/generic/patches-2.6.37/922-gpiommc.patch
+++ b/target/linux/generic/patches-2.6.37/922-gpiommc.patch
@@ -829,7 +829,7 @@
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -2696,6 +2696,11 @@ T:	git git://git.kernel.org/pub/scm/linu
+@@ -2706,6 +2706,11 @@ T:	git git://git.kernel.org/pub/scm/linu
  S:	Maintained
  F:	drivers/media/video/gspca/
  
diff --git a/target/linux/generic/patches-2.6.37/980-vm_exports.patch b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
index 09ccb397f2..5f0c3d4836 100644
--- a/target/linux/generic/patches-2.6.37/980-vm_exports.patch
+++ b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
@@ -48,7 +48,7 @@
  {
 --- a/kernel/exit.c
 +++ b/kernel/exit.c
-@@ -505,6 +505,7 @@ struct files_struct *get_files_struct(st
+@@ -513,6 +513,7 @@ struct files_struct *get_files_struct(st
  
  	return files;
  }
@@ -56,7 +56,7 @@
  
  void put_files_struct(struct files_struct *files)
  {
-@@ -526,6 +527,7 @@ void put_files_struct(struct files_struc
+@@ -534,6 +535,7 @@ void put_files_struct(struct files_struc
  		rcu_read_unlock();
  	}
  }
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4573,6 +4573,7 @@ int can_nice(const struct task_struct *p
+@@ -4588,6 +4588,7 @@ int can_nice(const struct task_struct *p
  	return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
  		capable(CAP_SYS_NICE));
  }
diff --git a/target/linux/generic/patches-2.6.37/999-use_preinit_as_init.patch b/target/linux/generic/patches-2.6.37/999-use_preinit_as_init.patch
index 650c677deb..e0a76229c1 100644
--- a/target/linux/generic/patches-2.6.37/999-use_preinit_as_init.patch
+++ b/target/linux/generic/patches-2.6.37/999-use_preinit_as_init.patch
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -845,10 +845,7 @@ static noinline int init_post(void)
+@@ -844,10 +844,7 @@ static noinline int init_post(void)
  		printk(KERN_WARNING "Failed to execute %s.  Attempting "
  					"defaults...\n", execute_command);
  	}
-- 
cgit v1.2.3