From 7c7ad6c9665516d16add04d7551c59542a320d23 Mon Sep 17 00:00:00 2001
From: Imre Kaloz <kaloz@openwrt.org>
Date: Tue, 23 Jun 2009 21:06:05 +0000
Subject: [coldfire] generate an uImage binary for now

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16549 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/coldfire/image/Makefile | 5 +++++
 1 file changed, 5 insertions(+)

(limited to 'target/linux/coldfire')

diff --git a/target/linux/coldfire/image/Makefile b/target/linux/coldfire/image/Makefile
index 5eb5c2f2f1..0228a8dcf6 100644
--- a/target/linux/coldfire/image/Makefile
+++ b/target/linux/coldfire/image/Makefile
@@ -13,6 +13,11 @@ define Image/Prepare
 endef
 
 define Image/BuildKernel
+	$(TARGET_CROSS)objcopy -O binary -R .bss -R .note -R .comment \
+		-R .note.gnu.build-id -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
+	mkimage -A m68k -O linux -T kernel -a 0x00020000 -e 0x00020000 \
+		-C none -n 'M68K OpenWrt Linux-$(LINUX_VERSION)' \
+		-d $(KDIR)/vmlinux.bin $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef
 
 define Image/Build
-- 
cgit v1.2.3