From 98d77709be8d55832ee273be0807a2ba0cb4cd5a Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 27 Sep 2012 18:30:07 +0000
Subject: [package] 6to4: properly setup Base6to4Interface (#12251)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33573 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/6to4/Makefile      |  2 +-
 package/6to4/files/6to4.sh | 13 +++++++++----
 2 files changed, 10 insertions(+), 5 deletions(-)

(limited to 'package')

diff --git a/package/6to4/Makefile b/package/6to4/Makefile
index fdf8627a45..f29571d86c 100644
--- a/package/6to4/Makefile
+++ b/package/6to4/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=10
+PKG_VERSION:=11
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/6to4/files/6to4.sh b/package/6to4/files/6to4.sh
index f518b02332..3a616f675b 100755
--- a/package/6to4/files/6to4.sh
+++ b/package/6to4/files/6to4.sh
@@ -108,10 +108,15 @@ proto_6to4_setup() {
 
 	( proto_add_host_dependency "$cfg" 0.0.0.0 )
 
+	local wanif
+	if ! network_find_wan wanif; then
+		proto_notify_error "$cfg" "NO_WAN_LINK"
+		return
+	fi
+
 	[ -z "$ipaddr" ] && {
-		local wanif
-		if ! network_find_wan wanif || ! network_get_ipaddr ipaddr "$wanif"; then
-			proto_notify_error "$cfg" "NO_WAN_LINK"
+		if ! network_get_ipaddr ipaddr "$wanif"; then
+			proto_notify_error "$cfg" "NO_WAN_ADDRESS"
 			return
 		fi
 	}
@@ -159,7 +164,7 @@ proto_6to4_setup() {
 
 			set_6to4_radvd_interface "$sid" "$adv_interface" "$mtu"
 			set_6to4_radvd_prefix    "$sid" "$adv_interface" \
-				"$wancfg" "$(printf "0:0:0:%x::/64" $adv_subnet)" \
+				"$wanif" "$(printf "0:0:0:%x::/64" $adv_subnet)" \
 				"$adv_valid_lifetime" "$adv_preferred_lifetime"
 
 			adv_subnets="${adv_subnets:+$adv_subnets }$adv_ifname:$subnet6"
-- 
cgit v1.2.3