From b4ce4197c731f12ff3094716d9f07a00f5dd2d13 Mon Sep 17 00:00:00 2001
From: Imre Kaloz <kaloz@openwrt.org>
Date: Mon, 3 Aug 2009 11:24:56 +0000
Subject: add special handling for the adm5120 target, which uses subtargets
 for different endianess -- later we should come up with something smarter

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17101 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/opkg/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'package/opkg')

diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 9f5faa3474..864a13b478 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -59,7 +59,7 @@ define Build/Compile
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		CC="$(TARGET_CC)" \
 		DESTDIR="$(PKG_INSTALL_DIR)" \
-		HOST_CPU="$(BOARD)" \
+		HOST_CPU="$(PKGARCH)" \
 		all install
 endef
 
@@ -68,7 +68,7 @@ define Package/opkg/install
 	$(INSTALL_DIR) $(1)/bin
 	$(INSTALL_DIR) $(1)/etc
 	$(INSTALL_DATA) ./files/opkg.conf $(1)/etc/
-	$(SED) 's,$$$$S,$(BOARD),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/opkg.conf
+	$(SED) 's,$$$$S,$(PKGARCH),g' $(1)/etc/opkg.conf
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
 	$(INSTALL_DIR) $(1)/usr/lib
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopkg.so.* $(1)/usr/lib/
-- 
cgit v1.2.3