aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/025-bcma_backport.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.14/025-bcma_backport.patch')
-rw-r--r--target/linux/generic/patches-3.14/025-bcma_backport.patch210
1 files changed, 198 insertions, 12 deletions
diff --git a/target/linux/generic/patches-3.14/025-bcma_backport.patch b/target/linux/generic/patches-3.14/025-bcma_backport.patch
index fd2fa5efc0..380e63d607 100644
--- a/target/linux/generic/patches-3.14/025-bcma_backport.patch
+++ b/target/linux/generic/patches-3.14/025-bcma_backport.patch
@@ -1,6 +1,9 @@
--- a/drivers/bcma/Makefile
+++ b/drivers/bcma/Makefile
-@@ -3,6 +3,7 @@ bcma-y += driver_chipcommon.o driver
+@@ -1,8 +1,10 @@
+ bcma-y += main.o scan.o core.o sprom.o
+ bcma-y += driver_chipcommon.o driver_chipcommon_pmu.o
++bcma-y += driver_chipcommon_b.o
bcma-$(CONFIG_BCMA_SFLASH) += driver_chipcommon_sflash.o
bcma-$(CONFIG_BCMA_NFLASH) += driver_chipcommon_nflash.o
bcma-y += driver_pci.o
@@ -241,7 +244,7 @@
MODULE_DEVICE_TABLE(pci, bcma_pci_bridge_tbl);
--- a/drivers/bcma/main.c
+++ b/drivers/bcma/main.c
-@@ -120,10 +120,53 @@ static void bcma_release_core_dev(struct
+@@ -120,56 +120,78 @@ static void bcma_release_core_dev(struct
kfree(core);
}
@@ -297,8 +300,10 @@
list_for_each_entry(core, &bus->cores, list) {
/* We support that cores ourself */
-@@ -132,44 +175,22 @@ static int bcma_register_cores(struct bc
+ switch (core->id.id) {
+ case BCMA_CORE_4706_CHIPCOMMON:
case BCMA_CORE_CHIPCOMMON:
++ case BCMA_CORE_NS_CHIPCOMMON_B:
case BCMA_CORE_PCI:
case BCMA_CORE_PCIE:
+ case BCMA_CORE_PCIE2:
@@ -348,7 +353,7 @@
}
#ifdef CONFIG_BCMA_DRIVER_MIPS
-@@ -246,6 +267,12 @@ int bcma_bus_register(struct bcma_bus *b
+@@ -246,6 +268,12 @@ int bcma_bus_register(struct bcma_bus *b
bcma_core_chipcommon_early_init(&bus->drv_cc);
}
@@ -361,7 +366,21 @@
/* Try to get SPROM */
err = bcma_sprom_get(bus);
if (err == -ENOENT) {
-@@ -281,6 +308,13 @@ int bcma_bus_register(struct bcma_bus *b
+@@ -260,6 +288,13 @@ int bcma_bus_register(struct bcma_bus *b
+ bcma_core_chipcommon_init(&bus->drv_cc);
+ }
+
++ /* Init CC core */
++ core = bcma_find_core(bus, BCMA_CORE_NS_CHIPCOMMON_B);
++ if (core) {
++ bus->drv_cc_b.core = core;
++ bcma_core_chipcommon_b_init(&bus->drv_cc_b);
++ }
++
+ /* Init MIPS core */
+ core = bcma_find_core(bus, BCMA_CORE_MIPS_74K);
+ if (core) {
+@@ -281,6 +316,13 @@ int bcma_bus_register(struct bcma_bus *b
bcma_core_pci_init(&bus->drv_pci[1]);
}
@@ -375,7 +394,7 @@
/* Init GBIT MAC COMMON core */
core = bcma_find_core(bus, BCMA_CORE_4706_MAC_GBIT_COMMON);
if (core) {
-@@ -289,7 +323,7 @@ int bcma_bus_register(struct bcma_bus *b
+@@ -289,7 +331,7 @@ int bcma_bus_register(struct bcma_bus *b
}
/* Register found cores */
@@ -384,7 +403,16 @@
bcma_info(bus, "Bus registered\n");
-@@ -326,8 +360,6 @@ int __init bcma_bus_early_register(struc
+@@ -307,6 +349,8 @@ void bcma_bus_unregister(struct bcma_bus
+ else if (err)
+ bcma_err(bus, "Can not unregister GPIO driver: %i\n", err);
+
++ bcma_core_chipcommon_b_free(&bus->drv_cc_b);
++
+ cores[0] = bcma_find_core(bus, BCMA_CORE_MIPS_74K);
+ cores[1] = bcma_find_core(bus, BCMA_CORE_PCIE);
+ cores[2] = bcma_find_core(bus, BCMA_CORE_4706_MAC_GBIT_COMMON);
+@@ -326,8 +370,6 @@ int __init bcma_bus_early_register(struc
struct bcma_device *core;
struct bcma_device_id match;
@@ -508,7 +536,16 @@
#define BCMA_CHIP_ID_BCM43224 43224
#define BCMA_PKG_ID_BCM43224_FAB_CSM 0x8
#define BCMA_PKG_ID_BCM43224_FAB_SMIC 0xa
-@@ -328,11 +332,11 @@ struct bcma_bus {
+@@ -263,7 +267,7 @@ struct bcma_device {
+ u8 core_unit;
+
+ u32 addr;
+- u32 addr1;
++ u32 addr_s[8];
+ u32 wrap;
+
+ void __iomem *io_addr;
+@@ -328,11 +332,12 @@ struct bcma_bus {
struct bcma_device *mapped_core;
struct list_head cores;
u8 nr_cores;
@@ -516,6 +553,7 @@
u8 num;
struct bcma_drv_cc drv_cc;
++ struct bcma_drv_cc_b drv_cc_b;
struct bcma_drv_pci drv_pci[2];
+ struct bcma_drv_pcie2 drv_pcie2;
struct bcma_drv_mips drv_mips;
@@ -713,7 +751,45 @@
{ BCMA_CORE_ARMCA9, "ARM Cortex A9 core (ihost)" },
{ BCMA_CORE_AMEMC, "AMEMC (DDR)" },
{ BCMA_CORE_ALTA, "ALTA (I2S)" },
-@@ -421,10 +421,13 @@ static int bcma_get_next_core(struct bcm
+@@ -276,7 +276,7 @@ static int bcma_get_next_core(struct bcm
+ struct bcma_device *core)
+ {
+ u32 tmp;
+- u8 i, j;
++ u8 i, j, k;
+ s32 cia, cib;
+ u8 ports[2], wrappers[2];
+
+@@ -314,6 +314,7 @@ static int bcma_get_next_core(struct bcm
+ /* Some specific cores don't need wrappers */
+ switch (core->id.id) {
+ case BCMA_CORE_4706_MAC_GBIT_COMMON:
++ case BCMA_CORE_NS_CHIPCOMMON_B:
+ /* Not used yet: case BCMA_CORE_OOB_ROUTER: */
+ break;
+ default:
+@@ -367,6 +368,7 @@ static int bcma_get_next_core(struct bcm
+ core->addr = tmp;
+
+ /* get & parse slave ports */
++ k = 0;
+ for (i = 0; i < ports[1]; i++) {
+ for (j = 0; ; j++) {
+ tmp = bcma_erom_get_addr_desc(bus, eromptr,
+@@ -376,9 +378,9 @@ static int bcma_get_next_core(struct bcm
+ /* pr_debug("erom: slave port %d "
+ * "has %d descriptors\n", i, j); */
+ break;
+- } else {
+- if (i == 0 && j == 0)
+- core->addr1 = tmp;
++ } else if (k < ARRAY_SIZE(core->addr_s)) {
++ core->addr_s[k] = tmp;
++ k++;
+ }
+ }
+ }
+@@ -421,10 +423,13 @@ static int bcma_get_next_core(struct bcm
core->io_addr = ioremap_nocache(core->addr, BCMA_CORE_SIZE);
if (!core->io_addr)
return -ENOMEM;
@@ -731,7 +807,7 @@
}
}
return 0;
-@@ -435,9 +438,6 @@ void bcma_init_bus(struct bcma_bus *bus)
+@@ -435,9 +440,6 @@ void bcma_init_bus(struct bcma_bus *bus)
s32 tmp;
struct bcma_chipinfo *chipinfo = &(bus->chipinfo);
@@ -741,7 +817,7 @@
INIT_LIST_HEAD(&bus->cores);
bus->nr_cores = 0;
-@@ -449,8 +449,6 @@ void bcma_init_bus(struct bcma_bus *bus)
+@@ -449,8 +451,6 @@ void bcma_init_bus(struct bcma_bus *bus)
chipinfo->pkg = (tmp & BCMA_CC_ID_PKG) >> BCMA_CC_ID_PKG_SHIFT;
bcma_info(bus, "Found chip with id 0x%04X, rev 0x%02X and package 0x%02X\n",
chipinfo->id, chipinfo->rev, chipinfo->pkg);
@@ -750,7 +826,7 @@
}
int bcma_bus_scan(struct bcma_bus *bus)
-@@ -460,8 +458,6 @@ int bcma_bus_scan(struct bcma_bus *bus)
+@@ -460,8 +460,6 @@ int bcma_bus_scan(struct bcma_bus *bus)
int err, core_num = 0;
@@ -910,3 +986,113 @@
/* BCMA PCI config space registers. */
#define BCMA_PCI_PMCSR 0x44
#define BCMA_PCI_PE 0x100
+--- a/drivers/usb/host/bcma-hcd.c
++++ b/drivers/usb/host/bcma-hcd.c
+@@ -237,7 +237,7 @@ static int bcma_hcd_probe(struct bcma_de
+ bcma_hcd_init_chip(dev);
+
+ /* In AI chips EHCI is addrspace 0, OHCI is 1 */
+- ohci_addr = dev->addr1;
++ ohci_addr = dev->addr_s[0];
+ if ((chipinfo->id == 0x5357 || chipinfo->id == 0x4749)
+ && chipinfo->rev == 0)
+ ohci_addr = 0x18009000;
+--- a/drivers/bcma/bcma_private.h
++++ b/drivers/bcma/bcma_private.h
+@@ -50,6 +50,10 @@ void bcma_chipco_serial_init(struct bcma
+ extern struct platform_device bcma_pflash_dev;
+ #endif /* CONFIG_BCMA_DRIVER_MIPS */
+
++/* driver_chipcommon_b.c */
++int bcma_core_chipcommon_b_init(struct bcma_drv_cc_b *ccb);
++void bcma_core_chipcommon_b_free(struct bcma_drv_cc_b *ccb);
++
+ /* driver_chipcommon_pmu.c */
+ u32 bcma_pmu_get_alp_clock(struct bcma_drv_cc *cc);
+ u32 bcma_pmu_get_cpu_clock(struct bcma_drv_cc *cc);
+--- /dev/null
++++ b/drivers/bcma/driver_chipcommon_b.c
+@@ -0,0 +1,61 @@
++/*
++ * Broadcom specific AMBA
++ * ChipCommon B Unit driver
++ *
++ * Copyright 2014, Hauke Mehrtens <hauke@hauke-m.de>
++ *
++ * Licensed under the GNU/GPL. See COPYING for details.
++ */
++
++#include "bcma_private.h"
++#include <linux/export.h>
++#include <linux/bcma/bcma.h>
++
++static bool bcma_wait_reg(struct bcma_bus *bus, void __iomem *addr, u32 mask,
++ u32 value, int timeout)
++{
++ unsigned long deadline = jiffies + timeout;
++ u32 val;
++
++ do {
++ val = readl(addr);
++ if ((val & mask) == value)
++ return true;
++ cpu_relax();
++ udelay(10);
++ } while (!time_after_eq(jiffies, deadline));
++
++ bcma_err(bus, "Timeout waiting for register %p\n", addr);
++
++ return false;
++}
++
++void bcma_chipco_b_mii_write(struct bcma_drv_cc_b *ccb, u32 offset, u32 value)
++{
++ struct bcma_bus *bus = ccb->core->bus;
++
++ writel(offset, ccb->mii + 0x00);
++ bcma_wait_reg(bus, ccb->mii + 0x00, 0x0100, 0x0000, 100);
++ writel(value, ccb->mii + 0x04);
++ bcma_wait_reg(bus, ccb->mii + 0x00, 0x0100, 0x0000, 100);
++}
++EXPORT_SYMBOL_GPL(bcma_chipco_b_mii_write);
++
++int bcma_core_chipcommon_b_init(struct bcma_drv_cc_b *ccb)
++{
++ if (ccb->setup_done)
++ return 0;
++
++ ccb->setup_done = 1;
++ ccb->mii = ioremap_nocache(ccb->core->addr_s[1], BCMA_CORE_SIZE);
++ if (!ccb->mii)
++ return -ENOMEM;
++
++ return 0;
++}
++
++void bcma_core_chipcommon_b_free(struct bcma_drv_cc_b *ccb)
++{
++ if (ccb->mii)
++ iounmap(ccb->mii);
++}
+--- a/include/linux/bcma/bcma_driver_chipcommon.h
++++ b/include/linux/bcma/bcma_driver_chipcommon.h
+@@ -644,6 +644,12 @@ struct bcma_drv_cc {
+ #endif
+ };
+
++struct bcma_drv_cc_b {
++ struct bcma_device *core;
++ u8 setup_done:1;
++ void __iomem *mii;
++};
++
+ /* Register access */
+ #define bcma_cc_read32(cc, offset) \
+ bcma_read32((cc)->core, offset)
+@@ -699,4 +705,6 @@ extern void bcma_pmu_spuravoid_pllupdate
+
+ extern u32 bcma_pmu_get_bus_clock(struct bcma_drv_cc *cc);
+
++void bcma_chipco_b_mii_write(struct bcma_drv_cc_b *ccb, u32 offset, u32 value);
++
+ #endif /* LINUX_BCMA_DRIVER_CC_H_ */