aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 6642ce40e3..e514855a67 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -84,6 +84,16 @@ $(eval $(call Require,working-g++, \
No working GNU C++ Compiler (g++) was found on your system. \
))
+define Require/ncurses
+ echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
+ gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out -lncurses -
+endef
+
+$(eval $(call Require,ncurses, \
+ No ncurses development files were not found on your system. \
+))
+
+
define Require/zlib
echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
gcc -include zlib.h -x c -o $(TMP_DIR)/a.out -lz -