diff options
author | Florian Fainelli <florian@openwrt.org> | 2007-07-18 14:11:44 +0000 |
---|---|---|
committer | Florian Fainelli <florian@openwrt.org> | 2007-07-18 14:11:44 +0000 |
commit | 19a52ea35d1988cc8c612db8bbce7e4240b07849 (patch) | |
tree | d3592f5819e991e114e56385b71b70c87e52b819 | |
parent | 650ee7c337f5788b7b59a3241746fb08e6b3d577 (diff) | |
download | master-31e0f0ae-19a52ea35d1988cc8c612db8bbce7e4240b07849.tar.gz master-31e0f0ae-19a52ea35d1988cc8c612db8bbce7e4240b07849.tar.bz2 master-31e0f0ae-19a52ea35d1988cc8c612db8bbce7e4240b07849.zip |
Add a USES_TGZ config.in variable, so that RB1xx profiles can use it
SVN-Revision: 8039
-rw-r--r-- | Config.in | 2 | ||||
-rwxr-xr-x | scripts/metadata.pl | 1 | ||||
-rw-r--r-- | target/Config.in | 3 | ||||
-rw-r--r-- | target/linux/adm5120-2.6/profiles/RB1xx.mk | 1 |
4 files changed, 6 insertions, 1 deletions
@@ -36,7 +36,7 @@ menu "Target Images" config TARGET_ROOTFS_TGZ bool "tgz" - default y if !USES_SQUASHFS && !USES_JFFS2 + default y if USES_TGZ depends !TARGET_ROOTFS_INITRAMFS help Build a compressed tar archive of the the root filesystem diff --git a/scripts/metadata.pl b/scripts/metadata.pl index 484d4205f4..313efe75db 100755 --- a/scripts/metadata.pl +++ b/scripts/metadata.pl @@ -253,6 +253,7 @@ sub target_config_features(@) { /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n"; /jffs2/ and $ret .= "\tselect USES_JFFS2\n"; /ext2/ and $ret .= "\tselect USES_EXT2\n"; + /tgz/ and $ret .= "\tselect USES_TGZ\n"; } return $ret; } diff --git a/target/Config.in b/target/Config.in index e506512726..627940eb2e 100644 --- a/target/Config.in +++ b/target/Config.in @@ -35,6 +35,9 @@ config USES_JFFS2 config USES_EXT2 bool +config USES_TGZ + bool + config PROFILE_KCONFIG bool diff --git a/target/linux/adm5120-2.6/profiles/RB1xx.mk b/target/linux/adm5120-2.6/profiles/RB1xx.mk index 9dd3de0973..3d61cedc85 100644 --- a/target/linux/adm5120-2.6/profiles/RB1xx.mk +++ b/target/linux/adm5120-2.6/profiles/RB1xx.mk @@ -8,6 +8,7 @@ define Profile/RouterBoard NAME:=RouterBoard RB1xx PACKAGES:=kmod-madwifi + FEATURES+=tgz endef define Profile/RouterBoard/Description |