aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 852fd4c1..a18bc455 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -39,6 +39,13 @@ mocks = [
'-Wl,--wrap=test_inw',
'-Wl,--wrap=test_outl',
'-Wl,--wrap=test_inl',
+ '-Wl,--wrap=usb_dev_get_by_vid_pid_number',
+ '-Wl,--wrap=libusb_set_configuration',
+ '-Wl,--wrap=libusb_claim_interface',
+ '-Wl,--wrap=libusb_control_transfer',
+ '-Wl,--wrap=libusb_release_interface',
+ '-Wl,--wrap=libusb_close',
+ '-Wl,--wrap=libusb_exit',
'-Wl,--gc-sections',
]