aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@nullcube.com>2015-05-31 13:13:12 +1200
committerAldo Cortesi <aldo@nullcube.com>2015-05-31 13:13:12 +1200
commit13ee54da86319e4a028279c4dce0967d8a786067 (patch)
treec915a2fe2d8582824195dbd7bd7c5d7ca9f4260b /setup.py
parenta05a70d8168a07c92b2a3ecbbb1958d85532efe3 (diff)
downloadmitmproxy-13ee54da86319e4a028279c4dce0967d8a786067.tar.gz
mitmproxy-13ee54da86319e4a028279c4dce0967d8a786067.tar.bz2
mitmproxy-13ee54da86319e4a028279c4dce0967d8a786067.zip
Remove dependency on PyOpenSSL, move version check into netlib.
There are a few more functions in the code that accesses PyOpenSSL directly that should probably also be moved to netlib. Later.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4fa64628..1a502b97 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,6 @@ if os.name != "nt":
deps = {
"netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
"pyasn1>0.1.2",
- "pyOpenSSL>=0.14",
"tornado>=4.0.2",
"configargparse>=0.9.3",
"pyperclip>=1.5.8",