aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index d8c0790f..e0b57380 100644
--- a/setup.py
+++ b/setup.py
@@ -29,22 +29,23 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f:
exec(f.read(), about)
-SETUPTOOLS_DEPENDENCY = "setuptools"
-CFFI_DEPENDENCY = "cffi>=0.8"
-SIX_DEPENDENCY = "six>=1.4.1"
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
+ "idna",
"pyasn1",
- SIX_DEPENDENCY,
- SETUPTOOLS_DEPENDENCY
+ "six>=1.4.1",
+ "setuptools"
]
if sys.version_info < (3, 4):
requirements.append("enum34")
+if sys.version_info < (3, 3):
+ requirements.append("ipaddress")
+
if platform.python_implementation() != "PyPy":
- requirements.append(CFFI_DEPENDENCY)
+ requirements.append("cffi>=0.8")
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
@@ -318,7 +319,6 @@ setup(
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: Implementation :: CPython",