aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/xm-test/Makefile.am')
-rw-r--r--tools/xm-test/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/xm-test/Makefile.am b/tools/xm-test/Makefile.am
new file mode 100644
index 0000000000..a065616ece
--- /dev/null
+++ b/tools/xm-test/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = ramdisk tests
+EXTRA_DIST = lib runtest.sh mkreport
+
+# Remove any pyc's, CVS dirs, and prune the skel dirs
+dist-hook:
+ find $(distdir) -name '*~' -delete -print
+ find $(distdir) -name '*.pyc' -delete -print
+ for i in Root Repository Entries; do \
+ find $(distdir) -name $$i -delete ;\
+ done
+ find $(distdir) -name CVS -delete
+ find $(distdir) -name '*.test' -delete
+ cd $(distdir)/ramdisk/skel && find . -empty -delete
+ chmod a+x $(distdir)/runtest.sh
+