aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorcl349@firebug.cl.cam.ac.uk <cl349@firebug.cl.cam.ac.uk>2005-06-07 13:21:38 +0000
committercl349@firebug.cl.cam.ac.uk <cl349@firebug.cl.cam.ac.uk>2005-06-07 13:21:38 +0000
commit3a834bf16537de45babbcec5200c7168349bb8f4 (patch)
treef050ced13d5e2f1613d0203c14eda75873201aaf /tools/python/setup.py
parent8359d0386f7304d8c3e1d5df96d428e685efafc4 (diff)
downloadxen-3a834bf16537de45babbcec5200c7168349bb8f4.tar.gz
xen-3a834bf16537de45babbcec5200c7168349bb8f4.tar.bz2
xen-3a834bf16537de45babbcec5200c7168349bb8f4.zip
bitkeeper revision 1.1662.1.17 (42a59f62TbTw4kErDSfuOYh8iAzCuA)
setup.py: Add xenstore python bindings. xs.c: new file params.py: XSDAEMON_DEBUG -> XENSTORED_DEBUG Makefile: xenstore is also a library -- build it before python. Signed-off-by: Mike Wray <mike.wray@hp.com> Signed-off-by: Christian Limpach <Christian.Limpach@cl.cam.ac.uk>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index e6b04f8708..5902d4151f 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -9,13 +9,15 @@ extra_compile_args = [ "-fno-strict-aliasing", "-Wall", "-Werror" ]
include_dirs = [ XEN_ROOT + "/tools/python/xen/lowlevel/xu",
XEN_ROOT + "/tools/libxc",
+ XEN_ROOT + "/tools/xenstore",
XEN_ROOT + "/tools/xcs",
]
library_dirs = [ XEN_ROOT + "/tools/libxc",
+ XEN_ROOT + "/tools/xenstore",
]
-libraries = [ "xc" ]
+libraries = [ "xc", "xenstore" ]
xc = Extension("xc",
extra_compile_args = extra_compile_args,
@@ -30,7 +32,14 @@ xu = Extension("xu",
library_dirs = library_dirs,
libraries = libraries,
sources = [ "xen/lowlevel/xu/xu.c" ])
-
+
+xs = Extension("xs",
+ extra_compile_args = extra_compile_args,
+ include_dirs = include_dirs + [ "xen/lowlevel/xs" ],
+ library_dirs = library_dirs,
+ libraries = libraries,
+ sources = [ "xen/lowlevel/xs/xs.c" ])
+
setup(name = 'xen',
version = '2.0',
description = 'Xen',
@@ -43,7 +52,7 @@ setup(name = 'xen',
'xen.web',
],
ext_package = "xen.lowlevel",
- ext_modules = [ xc, xu ]
+ ext_modules = [ xc, xu, xs ]
)
os.chdir('logging')