aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index efbeda7..63a00b4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,6 +8,9 @@
# $Id$
#
# $Log$
+# Revision 1.10 2008/02/13 18:05:06 james
+# *** empty log message ***
+#
# Revision 1.9 2008/02/13 16:57:29 james
# *** empty log message ***
#
@@ -41,12 +44,12 @@
INCLUDES=
-PROJECTHDRS= crt.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h log.h ipc.h context.h prototypes.h
+PROJECTHDRS= crt.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h log.h ipc.h context.h symsocket.h prototypes.h
HDRS=project.h
SRCS=ansi.c crt.c html.c libsympathy.c render.c version.c vt102.c tty.c \
- history.c ring.c ptty.c terminal.c util.c log.c ipc.c slide.c
+ history.c ring.c ptty.c terminal.c util.c log.c ipc.c slide.c symsocket.c
CPROTO=cproto
@@ -67,7 +70,7 @@ lib_LTLIBRARIES=libsympathy.la
include_HEADERS=sympathy.h
-AM_CFLAGS=-g
+AM_CFLAGS=-g -Werror
libsympathy_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
@@ -83,7 +86,7 @@ VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${V
protos:
echo > prototypes.h
- ${CPROTO} -v ${INCLUDES} ${SRCS} > prototypes.tmp
+ ${CPROTO} -e -v ${INCLUDES} ${SRCS} > prototypes.tmp
mv -f prototypes.tmp prototypes.h
tidy: ${SRCS} ${HDRS}