summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/esp32s2/boards/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/esp32s2/boards/CMakeLists.txt')
-rwxr-xr-xtinyusb/hw/bsp/esp32s2/boards/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/esp32s2/boards/CMakeLists.txt b/tinyusb/hw/bsp/esp32s2/boards/CMakeLists.txt
new file mode 100755
index 00000000..71753012
--- /dev/null
+++ b/tinyusb/hw/bsp/esp32s2/boards/CMakeLists.txt
@@ -0,0 +1,14 @@
+idf_component_register(SRCS esp32s2.c
+ INCLUDE_DIRS "." "${BOARD}"
+ PRIV_REQUIRES "driver"
+ REQUIRES freertos src led_strip)
+
+# Apply board specific content
+include("${BOARD}/board.cmake")
+
+idf_component_get_property( FREERTOS_ORIG_INCLUDE_PATH freertos ORIG_INCLUDE_PATH)
+target_include_directories(${COMPONENT_TARGET} PUBLIC
+ "${FREERTOS_ORIG_INCLUDE_PATH}"
+ "${TOP}/hw"
+ "${TOP}/src"
+)