summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/midi_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/examples/device/midi_test/CMakeLists.txt')
-rwxr-xr-xtinyusb/examples/device/midi_test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tinyusb/examples/device/midi_test/CMakeLists.txt b/tinyusb/examples/device/midi_test/CMakeLists.txt
new file mode 100755
index 00000000..abc4d91d
--- /dev/null
+++ b/tinyusb/examples/device/midi_test/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 3.5)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/../../../hw/bsp/family_support.cmake)
+
+# gets PROJECT name for the example (e.g. <BOARD>-<DIR_NAME>)
+family_get_project_name(PROJECT ${CMAKE_CURRENT_LIST_DIR})
+
+project(${PROJECT})
+
+# Checks this example is valid for the family and initializes the project
+family_initialize_project(${PROJECT} ${CMAKE_CURRENT_LIST_DIR})
+
+add_executable(${PROJECT})
+
+# Example source
+target_sources(${PROJECT} PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/main.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/usb_descriptors.c
+ )
+
+# Example include
+target_include_directories(${PROJECT} PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR}/src
+ )
+
+# Configure compilation flags and libraries for the example... see the corresponding function
+# in hw/bsp/FAMILY/family.cmake for details.
+family_configure_device_example(${PROJECT}) \ No newline at end of file