From 7c727c6fa427dba9e43aaf3648d12af19a4858f1 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jo@mein.io>
Date: Tue, 18 Jul 2017 22:50:11 +0200
Subject: tools: expat: fix build on older host systems

Expat release 2.2.2 requires support for either syscall(SYS_getrandom) which
is available on Linux 3.17 or support for getrandom() which is only available
in glibc 2.25 or later.

Since some of our builders still run on Linux 3.16, we need to forcibly
disable the use of getrandom() for the host builds.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
 tools/expat/Makefile | 3 +++
 1 file changed, 3 insertions(+)

(limited to 'tools')

diff --git a/tools/expat/Makefile b/tools/expat/Makefile
index 697d3f60d1..246089d609 100644
--- a/tools/expat/Makefile
+++ b/tools/expat/Makefile
@@ -18,6 +18,9 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_VARS += \
+	CPPFLAGS="$(HOST_CFLAGS) -DXML_POOR_ENTROPY"
+
 define Host/Install
 	$(MAKE) -C $(HOST_BUILD_DIR) install
 endef
-- 
cgit v1.2.3