From 151cd2e5377e7aec50a40b93f71dc6f5b5b37de9 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 25 Oct 2012 16:39:38 +0000
Subject: b43-tools: get rid of the libfl dependency to fix build errors on mac
 os x

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33934 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 tools/b43-tools/Makefile                   |  1 +
 tools/b43-tools/patches/002-no_libfl.patch | 14 ++++++++++++++
 2 files changed, 15 insertions(+)
 create mode 100644 tools/b43-tools/patches/002-no_libfl.patch

(limited to 'tools')

diff --git a/tools/b43-tools/Makefile b/tools/b43-tools/Makefile
index 391eb2551a..d58a20e6a8 100644
--- a/tools/b43-tools/Makefile
+++ b/tools/b43-tools/Makefile
@@ -29,6 +29,7 @@ define Host/Compile
 	+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/assembler \
 		CFLAGS="$(HOST_CFLAGS) -include endian.h" \
 		$(HOST_MAKE_FLAGS) \
+		LDFLAGS= \
 		$(1) QUIET_SPARSE=:
 endef
 
diff --git a/tools/b43-tools/patches/002-no_libfl.patch b/tools/b43-tools/patches/002-no_libfl.patch
new file mode 100644
index 0000000000..2e55b0803b
--- /dev/null
+++ b/tools/b43-tools/patches/002-no_libfl.patch
@@ -0,0 +1,14 @@
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1268,6 +1268,11 @@ static void initialize(void)
+ #endif /* YYDEBUG */
+ }
+ 
++int yywrap(void)
++{
++	return 1;
++}
++
+ int main(int argc, char **argv)
+ {
+ 	int err, res = 1;
-- 
cgit v1.2.3