From bcb1d9c43baf17e0cb09a2d3c6af13d07ee45d57 Mon Sep 17 00:00:00 2001
From: John Crispin <blogic@openwrt.org>
Date: Sun, 16 Dec 2012 10:03:18 +0000
Subject: [lantiq] fix i2c-lantiq module

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34712 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/lantiq/modules.mk | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

(limited to 'target')

diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
index 9022318703..e7fbad3a29 100644
--- a/target/linux/lantiq/modules.mk
+++ b/target/linux/lantiq/modules.mk
@@ -5,18 +5,18 @@
 # See /LICENSE for more information.
 #
 
-I2C_FALCON_MODULES:= \
-  CONFIG_I2C_FALCON:drivers/i2c/busses/i2c-falcon
+I2C_LANTIQ_MODULES:= \
+  CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
 
-define KernelPackage/i2c-falcon-lantiq
-  TITLE:=Falcon I2C controller
-  $(call i2c_defaults,$(I2C_FALCON_MODULES),52)
-  DEPENDS:=kmod-i2c-core @(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
+define KernelPackage/i2c-lantiq
+  TITLE:=Lantiq I2C controller
+  $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+  DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
 endef
 
-define KernelPackage/i2c-falcon-lantiq/description
-  Kernel support for the Falcon I2C controller
+define KernelPackage/i2c-lantiq/description
+  Kernel support for the Lantiq/Falcon I2C controller
 endef
 
-$(eval $(call KernelPackage,i2c-falcon-lantiq))
+$(eval $(call KernelPackage,i2c-lantiq))
 
-- 
cgit v1.2.3