From 43d2eb64ccb3a223ba2244faee1280aaa6f68d11 Mon Sep 17 00:00:00 2001
From: Imre Kaloz <kaloz@openwrt.org>
Date: Sun, 18 Nov 2012 18:52:38 +0000
Subject: [generic]: add 3.7-rc6 support (patch 820 still has to be fixed)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34247 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 .../generic/patches-3.7/722-phy_mvswitch.patch     | 23 ++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 target/linux/generic/patches-3.7/722-phy_mvswitch.patch

(limited to 'target/linux/generic/patches-3.7/722-phy_mvswitch.patch')

diff --git a/target/linux/generic/patches-3.7/722-phy_mvswitch.patch b/target/linux/generic/patches-3.7/722-phy_mvswitch.patch
new file mode 100644
index 0000000000..fe6a7d311a
--- /dev/null
+++ b/target/linux/generic/patches-3.7/722-phy_mvswitch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -128,6 +128,10 @@ config ADM6996_PHY
+ 	  Currently supports the ADM6996FC and ADM6996M switches.
+ 	  Support for FC is very limited.
+ 
++config MVSWITCH_PHY
++	tristate "Driver for Marvell 88E6060 switches"
++	select ETHERNET_PACKET_MANGLE
++
+ config FIXED_PHY
+ 	bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ 	depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_BCM63XX_PHY)	+= bcm63xx.o
+ obj-$(CONFIG_BCM87XX_PHY)	+= bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY)	+= icplus.o
+ obj-$(CONFIG_ADM6996_PHY)	+= adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY)	+= mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY)	+= realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY)	+= et1011c.o
+ obj-$(CONFIG_FIXED_PHY)		+= fixed.o
-- 
cgit v1.2.3