From ccc0817067fb6ce5af071cb4f35b0d6b16a82585 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Fri, 1 Oct 2010 07:09:29 +0000
Subject: ar71xx: initial support for jjPlus JWAP003

Patch-by: Cezary Jackiewicz <cezary@eko.one.pl>

(the GPIODEV code has been removed, the sysfs interface
can be used to control the GPIO lines instead - juhosg)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23165 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/ar71xx/image/Makefile | 5 +++++
 1 file changed, 5 insertions(+)

(limited to 'target/linux/ar71xx/image/Makefile')

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 42db6e4943..cb342a1962 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -470,6 +470,10 @@ define Image/Build/Profile/EAP7660D
 	$(call Image/Build/Template/$(fs_128k)/$(1),PB4X,eap7660d,board=EAP7660D)
 endef
 
+define Image/Build/Profile/JWAP003
+	$(call Image/Build/Template/$(fs_64k)/$(1),PB4X,jwap003,board=JWAP003)
+endef
+
 define Image/Build/Profile/FR54RTR
 	$(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,fr-54rtr,board=DIR-600-A1,"AP91-AR7240-RT-090223-01")
 endef
@@ -616,6 +620,7 @@ define Image/Build/Profile/Default
 	$(call Image/Build/Profile/DIR825B1,$(1))
 	$(call Image/Build/Profile/EAP7660D,$(1))
 	$(call Image/Build/Profile/FR54RTR,$(1))
+	$(call Image/Build/Profile/JWAP003,$(1))
 	$(call Image/Build/Profile/MZKW04NU,$(1))
 	$(call Image/Build/Profile/MZKW300NH,$(1))
 	$(call Image/Build/Profile/PB42,$(1))
-- 
cgit v1.2.3