From b413f797cfcace585a258478a18e1d4bb1faca8e Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jogo@openwrt.org>
Date: Sun, 14 Aug 2011 23:36:45 +0000
Subject: package/kernel: kmod-hid: can't mix and match DEPENDS:= and $(call
 SetDepends/...)

Since the SetDepends macro does a:

  DEPENDS:= ...

it can't be used after setting DEPENDS:= explicitly, or it will clobber the previous value.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>

SVN-Revision: 27983
---
 package/kernel/modules/other.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

(limited to 'package')

diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index e67c41b72e..1e252e3746 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -252,12 +252,11 @@ $(eval $(call KernelPackage,gpio-nxp-74hc164))
 define KernelPackage/hid
   SUBMENU:=$(OTHER_MENU)
   TITLE:=HID Devices
-  DEPENDS:=+kmod-input-evdev
   KCONFIG:=CONFIG_HID
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
   $(call SetDepends/hid)
-  $(call AddDepends/input)
+  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/hid/description
-- 
cgit v1.2.3