From 20b6e014a61a9b40c30fab8184a9abd17f55085b Mon Sep 17 00:00:00 2001
From: Daniel Golle <daniel@makrotopia.org>
Date: Sat, 6 Mar 2021 04:18:10 +0000
Subject: kernel: fix kmod-usb3 on platforms without PCI

Partially restore the wild-card matching for kmod-usb3 modules to fix
build on platforms without PCI which otherwise file, as seen on
buildbot:

ERROR: module '[...]/linux-5.4.102/drivers/usb/host/xhci-pci.ko' is missing.
modules/usb.mk:1675: recipe for target '[...]/kmod-usb3_5.4.102-1_mips_mips32.ipk' failed

Fixes: 7bda2e9aba ("kernel: fix kmod-usb3 dependencies")
Fixes: be23f9818a ("apm821xx: add support for kernel 5.10")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 package/kernel/linux/modules/usb.mk | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

(limited to 'package')

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 1a45fb3670..3689f2d7c6 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1649,6 +1649,10 @@ endef
 
 $(eval $(call KernelPackage,usbmon))
 
+XHCI_MODULES := xhci-pci xhci-plat-hcd
+XHCI_FILES := $(wildcard $(patsubst %,$(LINUX_DIR)/drivers/usb/host/%.ko,$(XHCI_MODULES)))
+XHCI_AUTOLOAD := $(patsubst $(LINUX_DIR)/drivers/usb/host/%.ko,%,$(XHCI_FILES))
+
 define KernelPackage/usb3
   TITLE:=Support for USB3 controllers
   DEPENDS:= \
@@ -1662,9 +1666,8 @@ define KernelPackage/usb3
 	CONFIG_USB_XHCI_PCI \
 	CONFIG_USB_XHCI_PLATFORM
   FILES:= \
-	$(LINUX_DIR)/drivers/usb/host/xhci-pci.ko \
-	$(LINUX_DIR)/drivers/usb/host/xhci-plat-hcd.ko
-  AUTOLOAD:=$(call AutoLoad,54,xhci-pci xhci-plat-hcd,1)
+	$(XHCI_FILES)
+  AUTOLOAD:=$(call AutoLoad,54,$(XHCI_AUTOLOAD),1)
   $(call AddDepends/usb)
 endef
 
-- 
cgit v1.2.3