From 79b3d8f69aa02e2dc80f04a1ac84e971a2a33f8b Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Tue, 1 Feb 2011 14:30:38 +0000
Subject: * rename lqdsl packages to ltq-dsl * small rework of packages * make
 it work with latest kernel

SVN-Revision: 25274
---
 package/lqdsl-app/Makefile                      | 81 -------------------------
 package/lqdsl-app/files/ifx_cpe_control_init.sh | 21 -------
 2 files changed, 102 deletions(-)
 delete mode 100644 package/lqdsl-app/Makefile
 delete mode 100644 package/lqdsl-app/files/ifx_cpe_control_init.sh

(limited to 'package/lqdsl-app')

diff --git a/package/lqdsl-app/Makefile b/package/lqdsl-app/Makefile
deleted file mode 100644
index 18ce2a9a54..0000000000
--- a/package/lqdsl-app/Makefile
+++ /dev/null
@@ -1,81 +0,0 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# ralph / blogic
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_BASE_NAME:=dsl_cpe_control_danube
-PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
-PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/lqdsl-app
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Lantiq DSL userland tool
-  URL:=http://www.lantiq.com/
-  MAINTAINER:=Lantiq
-  DEPENDS:=@TARGET_lantiq_xway +kmod-lqdsl +libpthread
-endef
-
-define Package/lqdsl-app/description
-	Infineon DSL CPE API for Amazon SE, Danube and Vinax.
-endef
-
-IFX_DSL_MAX_DEVICE=1
-IFX_DSL_LINES_PER_DEVICE=1
-IFX_DSL_CHANNELS_PER_LINE=1
-#CONFIG_IFX_CLI=y
-
-CONFIGURE_ARGS += \
-	--with-max-device="$(IFX_DSL_MAX_DEVICE)" \
-	--with-lines-per-device="$(IFX_DSL_LINES_PER_DEVICE)" \
-	--with-channels-per-line="$(IFX_DSL_CHANNELS_PER_LINE)" \
-	--enable-danube \
-	--enable-driver-include="-I$(STAGING_DIR)/usr/include" \
-	--enable-debug-prints \
-	--enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
-	--enable-cmv-scripts \
-	--enable-debug-tool-interface \
-	--enable-adsl-led \
-	--enable-dsl-ceoc \
-	--enable-script-notification \
-	--enable-dsl-pm \
-	--enable-dsl-pm-total \
-	--enable-dsl-pm-history \
-	--enable-dsl-pm-showtime \
-	--enable-dsl-pm-channel-counters \
-	--enable-dsl-pm-datapath-counters \
-	--enable-dsl-pm-line-counters \
-	--enable-dsl-pm-channel-thresholds \
-	--enable-dsl-pm-datapath-thresholds \
-	--enable-dsl-pm-line-thresholds \
-	--enable-dsl-pm-optional-parameters
-
-ifeq ($(CONFIG_IFX_CLI),y)
-CONFIGURE_ARGS += \
-	--enable-cli-support \
-	--enable-soap-support
-endif
-
-TARGET_CFLAGS += -I$(LINUX_DIR)/include
-
-define Package/lqdsl-app/install
-	$(INSTALL_DIR) $(1)/etc/init.d
-	$(INSTALL_BIN) ./files/ifx_cpe_control_init.sh $(1)/etc/init.d/
-
-	$(INSTALL_DIR) $(1)/sbin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
-endef
-
-$(eval $(call BuildPackage,lqdsl-app))
diff --git a/package/lqdsl-app/files/ifx_cpe_control_init.sh b/package/lqdsl-app/files/ifx_cpe_control_init.sh
deleted file mode 100644
index 91316938ce..0000000000
--- a/package/lqdsl-app/files/ifx_cpe_control_init.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
-START=99
-
-start() {
-
-	# start CPE dsl daemon in the background
-	/sbin/dsl_cpe_control -i -f /lib/firmware/ModemHWE.bin &
-
-#	PS=`ps`
-#	echo $PS | grep -q dsl_cpe_control && {
-#		# workaround for nfs: allow write to pipes for non-root
-#		while [ ! -e /tmp/pipe/dsl_cpe1_ack ] ; do sleep 1; done
-#		chmod a+w /tmp/pipe/dsl_*
-#	}
-	echo $PS | grep -q dsl_cpe_control || {
-		echo "Start of dsl_cpe_control failed!!!"
-		false
-	}
-
-}
-- 
cgit v1.2.3