From f51dc17eddff60d46009ca85c2ee50c46ca7d9df Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 5 Jan 2015 13:02:08 +0000
Subject: kernel/modules: add kmod-crypto-ghash

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>

SVN-Revision: 43837
---
 package/kernel/linux/modules/crypto.mk | 12 ++++++++++++
 1 file changed, 12 insertions(+)

(limited to 'package/kernel/linux')

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index eec7934f16..9d69cce9d5 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -411,6 +411,18 @@ endef
 $(eval $(call KernelPackage,crypto-gf128))
 
 
+define KernelPackage/crypto-ghash
+  TITLE:=GHASH digest CryptoAPI module
+  DEPENDS:=+kmod-crypto-gf128
+  KCONFIG:=CONFIG_CRYPTO_GHASH
+  FILES:=$(LINUX_DIR)/crypto/ghash-generic.ko
+  AUTOLOAD:=$(call AutoLoad,09,ghash-generic)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ghash))
+
+
 define KernelPackage/crypto-md4
   TITLE:=MD4 digest CryptoAPI module
   DEPENDS:=+kmod-crypto-hash
-- 
cgit v1.2.3