From 90f0d47a03d02e6b19d24b6a745fe30de1e03418 Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 2 Jun 2011 14:38:01 +0000
Subject: soloscli: fix new lines in soloscli

If the string received from the ADSL firmware is missing \n, add it in.

Signed-off-by: Nathan Williams <nathan@traverse.com.au>

SVN-Revision: 27096
---
 package/soloscli/Makefile                  | 4 ++--
 package/soloscli/patches/001-newline.patch | 8 ++++++--
 2 files changed, 8 insertions(+), 4 deletions(-)

diff --git a/package/soloscli/Makefile b/package/soloscli/Makefile
index 1c2d998090..490186dbec 100644
--- a/package/soloscli/Makefile
+++ b/package/soloscli/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=soloscli
 PKG_VERSION:=0.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/openadsl
diff --git a/package/soloscli/patches/001-newline.patch b/package/soloscli/patches/001-newline.patch
index 69cd5b28a6..4b663e8898 100644
--- a/package/soloscli/patches/001-newline.patch
+++ b/package/soloscli/patches/001-newline.patch
@@ -1,11 +1,15 @@
 --- a/soloscli/soloscli.c
 +++ b/soloscli/soloscli.c
-@@ -238,7 +238,7 @@
+@@ -238,7 +238,11 @@
  	}
  	if (strcmp(buf,pid) == 0) {
  /*		printf("Sequence matches.\n"); */
 -		printf("%s",bufp);
-+		printf("%s\n",bufp);
++		if(buf[(len-1)] == '\n'){
++			printf("%s",bufp);
++		} else {
++			printf("%s\n",bufp);
++		}
  	} else {
  		printf("Sequence incorrect.\n");
  		buf[i] = '\n';
-- 
cgit v1.2.3