From 4f73613c2698346102741b27a8524076eb66c20c Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 16 Oct 2014 10:30:16 +0000
Subject: build: improve feed handling for opkg.conf

 - Consider not installed feeds as well
 - Add option to decide whether to comment disabled feeds

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 42931
---
 include/feeds.mk                   |  4 +++-
 package/base-files/image-config.in | 11 +++++++++--
 package/system/opkg/Makefile       |  2 +-
 3 files changed, 13 insertions(+), 4 deletions(-)

diff --git a/include/feeds.mk b/include/feeds.mk
index 97b14491f0..695b03b145 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -10,10 +10,12 @@
 FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
 FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
 FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
-FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
 
 PKG_CONFIG_DEPENDS += \
 	CONFIG_PER_FEED_REPO \
+	CONFIG_PER_FEED_REPO_ADD_DISABLED \
+	CONFIG_PER_FEED_REPO_ADD_COMMENTED \
 	$(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
 
 # 1: package name
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 67604cdd54..c679a5b33a 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -217,11 +217,18 @@ menuconfig PER_FEED_REPO
 		for the core packages and each enabled feed.
 
 	config PER_FEED_REPO_ADD_DISABLED
-		bool "Add installed but disabled feeds to opkg.conf"
+		bool "Add available but not enabled feeds to opkg.conf"
 		default y
 		depends on PER_FEED_REPO
 		help
-		  Add installed but disabled feeds as commented out source lines to opkg.conf.
+		  Add not installed or disabled feeds from feeds.conf to opkg.conf.
+
+	config PER_FEED_REPO_ADD_COMMENTED
+		bool "Comment out not enabled feeds"
+		default y
+		depends on PER_FEED_REPO && PER_FEED_REPO_ADD_DISABLED
+		help
+		  Add not enabled feeds as commented out source lines to opkg.conf.
 
 source "tmp/.config-feeds.in"
 
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 8a63fb4352..6dd3f31818 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -113,7 +113,7 @@ define Package/opkg/Default/install
 	done
     ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
 	for d in $(FEEDS_DISABLED); do \
-		echo "# src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
+		echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
 	done
     endif
   endif
-- 
cgit v1.2.3