From 31876c193aaa8ddbe6c5758aee5754aee257fc44 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 18 Mar 2013 16:11:32 +0000
Subject: hostapd: fix build errors on supplicant-only builds

SVN-Revision: 36085
---
 package/network/services/hostapd/Makefile                       | 4 +++-
 package/network/services/hostapd/patches/700-ubus_support.patch | 6 +++---
 2 files changed, 6 insertions(+), 4 deletions(-)

diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 0c44a8b08d..7024844d10 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -225,7 +225,9 @@ TARGET_CPPFLAGS := \
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
-TARGET_LDFLAGS += -lubox -lubus
+ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
+  TARGET_LDFLAGS += -lubox -lubus
+endif
 
 ifdef CONFIG_PACKAGE_kmod-mac80211
   TARGET_LDFLAGS += -lm -lnl-tiny
diff --git a/package/network/services/hostapd/patches/700-ubus_support.patch b/package/network/services/hostapd/patches/700-ubus_support.patch
index 92ca7b21ca..ad1a45bf38 100644
--- a/package/network/services/hostapd/patches/700-ubus_support.patch
+++ b/package/network/services/hostapd/patches/700-ubus_support.patch
@@ -422,14 +422,14 @@
 +	const u8 *addr;
 +};
 +
++struct hostapd_iface;
++struct hostapd_data;
++
 +#ifdef UBUS_SUPPORT
 +
 +#include <libubox/avl.h>
 +#include <libubus.h>
 +
-+struct hostapd_iface;
-+struct hostapd_data;
-+
 +struct hostapd_ubus_iface {
 +	struct ubus_object obj;
 +};
-- 
cgit v1.2.3