From 2f2a913440e36a5e476a0906ae46a9f05f90013c Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jogo@openwrt.org>
Date: Fri, 19 Jul 2013 13:20:39 +0000
Subject: x86: switch rdc to to gpio_keys_polled

gpio_buttons have been deprecated since a long time.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37435 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/x86/patches-3.3/100-rdc_boards.patch | 10 +++++-----
 target/linux/x86/patches-3.7/100-rdc_boards.patch | 10 +++++-----
 target/linux/x86/patches-3.8/100-rdc_boards.patch | 10 +++++-----
 target/linux/x86/rdc/target.mk                    |  3 +--
 4 files changed, 16 insertions(+), 17 deletions(-)

diff --git a/target/linux/x86/patches-3.3/100-rdc_boards.patch b/target/linux/x86/patches-3.3/100-rdc_boards.patch
index 958bee0064..b3cbda226f 100644
--- a/target/linux/x86/patches-3.3/100-rdc_boards.patch
+++ b/target/linux/x86/patches-3.3/100-rdc_boards.patch
@@ -67,7 +67,7 @@
 +
 +/* Button */
 +static struct platform_device rdc321x_buttons = {
-+	.name = "gpio-buttons",
++	.name = "gpio-keys-polled",
 +	.id = -1,
 +	.dev = {
 +		.platform_data = &rdcplat_data.button_data,
@@ -187,7 +187,7 @@
 +static struct gpio_led ar525w_leds[] = {
 +	{ .name = "rdc321x:dmz", .gpio = 1, .active_low = 1},
 +};
-+static struct gpio_button ar525w_btns[] = {
++static struct gpio_keys_button ar525w_btns[] = {
 +	{
 +		.gpio = 6,
 +		.code = BTN_0,
@@ -584,7 +584,7 @@
 +	{ .name = "rdc321x:usb1", .gpio = 1, .active_low = 1},
 +};
 +
-+static struct gpio_button sitecom_btns[] = {
++static struct gpio_keys_button sitecom_btns[] = {
 +	{
 +		.gpio = 6,
 +		.code = BTN_0,
@@ -731,11 +731,11 @@
 +#define _RDC_BOARDS_H__
 +
 +#include <linux/leds.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +
 +struct rdc_platform_data {
 +	struct gpio_led_platform_data led_data;
-+	struct gpio_buttons_platform_data button_data;
++	struct gpio_keys_platform_data button_data;
 +};
 +
 +#endif
diff --git a/target/linux/x86/patches-3.7/100-rdc_boards.patch b/target/linux/x86/patches-3.7/100-rdc_boards.patch
index 48c42f7adf..462808e354 100644
--- a/target/linux/x86/patches-3.7/100-rdc_boards.patch
+++ b/target/linux/x86/patches-3.7/100-rdc_boards.patch
@@ -67,7 +67,7 @@
 +
 +/* Button */
 +static struct platform_device rdc321x_buttons = {
-+	.name = "gpio-buttons",
++	.name = "gpio-keys-polled",
 +	.id = -1,
 +	.dev = {
 +		.platform_data = &rdcplat_data.button_data,
@@ -187,7 +187,7 @@
 +static struct gpio_led ar525w_leds[] = {
 +	{ .name = "rdc321x:dmz", .gpio = 1, .active_low = 1},
 +};
-+static struct gpio_button ar525w_btns[] = {
++static struct gpio_keys_button ar525w_btns[] = {
 +	{
 +		.gpio = 6,
 +		.code = BTN_0,
@@ -584,7 +584,7 @@
 +	{ .name = "rdc321x:usb1", .gpio = 1, .active_low = 1},
 +};
 +
-+static struct gpio_button sitecom_btns[] = {
++static struct gpio_keys_button sitecom_btns[] = {
 +	{
 +		.gpio = 6,
 +		.code = BTN_0,
@@ -731,11 +731,11 @@
 +#define _RDC_BOARDS_H__
 +
 +#include <linux/leds.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +
 +struct rdc_platform_data {
 +	struct gpio_led_platform_data led_data;
-+	struct gpio_buttons_platform_data button_data;
++	struct gpio_keys_platform_data button_data;
 +};
 +
 +#endif
diff --git a/target/linux/x86/patches-3.8/100-rdc_boards.patch b/target/linux/x86/patches-3.8/100-rdc_boards.patch
index 5880610366..c70874ae8e 100644
--- a/target/linux/x86/patches-3.8/100-rdc_boards.patch
+++ b/target/linux/x86/patches-3.8/100-rdc_boards.patch
@@ -67,7 +67,7 @@
 +
 +/* Button */
 +static struct platform_device rdc321x_buttons = {
-+	.name = "gpio-buttons",
++	.name = "gpio-keys-polled",
 +	.id = -1,
 +	.dev = {
 +		.platform_data = &rdcplat_data.button_data,
@@ -187,7 +187,7 @@
 +static struct gpio_led ar525w_leds[] = {
 +	{ .name = "rdc321x:dmz", .gpio = 1, .active_low = 1},
 +};
-+static struct gpio_button ar525w_btns[] = {
++static struct gpio_keys_button ar525w_btns[] = {
 +	{
 +		.gpio = 6,
 +		.code = BTN_0,
@@ -584,7 +584,7 @@
 +	{ .name = "rdc321x:usb1", .gpio = 1, .active_low = 1},
 +};
 +
-+static struct gpio_button sitecom_btns[] = {
++static struct gpio_keys_button sitecom_btns[] = {
 +	{
 +		.gpio = 6,
 +		.code = BTN_0,
@@ -731,11 +731,11 @@
 +#define _RDC_BOARDS_H__
 +
 +#include <linux/leds.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +
 +struct rdc_platform_data {
 +	struct gpio_led_platform_data led_data;
-+	struct gpio_buttons_platform_data button_data;
++	struct gpio_keys_platform_data button_data;
 +};
 +
 +#endif
diff --git a/target/linux/x86/rdc/target.mk b/target/linux/x86/rdc/target.mk
index 959a8a1d15..c9589452b0 100644
--- a/target/linux/x86/rdc/target.mk
+++ b/target/linux/x86/rdc/target.mk
@@ -5,8 +5,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
 		    wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
-		    kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
-		    kmod-rdc321x-wdt
+		    kmod-input-polldev kmod-button-hotplug kmod-rdc321x-wdt
 
 define Target/Description
         Build firmware images for RDC321x based routers
-- 
cgit v1.2.3