aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/dts/wap-5813n.dts
Commit message (Collapse)AuthorAgeFilesLines
* brcm63xx: use more systematic names for image and DTS filesAdrian Schmutzler2020-02-081-157/+0
| | | | | | | | | | | | | | | | | | | | This changes brcm63xx target to achieve consistency between image names, device nodes names, compatible, DTS name and device name as much as possible. As with other targets, having consistent names is supposed to make life easier for developers and reduces the number of "variables" in the system. In particular, applying the DTS scheme will make it easier to find the correct file and architecture. DTS files are named based on the increasingly common soc-vendor-model scheme, using hyphens for separation as this seems to be the kernel way. Since the compatible is not used at the moment, I took the chance to also align them with this patch. For the SOC, the already existing CFE_CHIP_ID can be exploiting for all but two devices. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
* brcm63xx: dts: Unify naming of gpio-led nodesPetr Štetiar2019-02-051-1/+1
| | | | | | | | | | | | | | In DTS Checklist[1] we're now demanding proper generic node names, as the name of a node should reflect the function of the device and use generic name for that[2]. Everybody seems to be copy&pasting from DTS files available in the repository today, so let's unify that naming there as well and provide proper examples. 1. https://openwrt.org/submitting-patches#dts_checklist 2. https://github.com/devicetree-org/devicetree-specification/blob/master/source/devicetree-basics.rst#generic-names-recommendation Signed-off-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [split up]
* brcm63xx: dts: Unify naming of gpio-keys nodesPetr Štetiar2019-02-051-1/+1
| | | | | | | | | | | | | | In DTS Checklist[1] we're now demanding proper generic node names, as the name of a node should reflect the function of the device and use generic name for that[2]. Everybody seems to be copy&pasting from DTS files available in the repository today, so let's unify that naming there as well and provide proper examples. 1. https://openwrt.org/submitting-patches#dts_checklist 2. https://github.com/devicetree-org/devicetree-specification/blob/master/source/devicetree-basics.rst#generic-names-recommendation Signed-off-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [split up]
* ath79, brcm63xx: Fix debounce-interval properties in gpio-keys-polled nodesPetr Štetiar2018-12-171-1/+5
| | | | | | | | | | | | | | | | | | | | | | | | | This patch fixes wrong usage of debounce-interval subnode property of gpio-keys-polled nodes, which was used inproperly in parent node, but it belongs to the subnodes, excerpt from the docs: Optional subnode-properties: - debounce-interval: Debouncing interval time in milliseconds. If not specified defaults to 5. And the docs are up to date as the source code matches that description as well: if (fwnode_property_read_u32(child, "debounce-interval", &button->debounce_interval)) button->debounce_interval = 5; While at it, I've also re-formatted gpio-keys-polled nodes, usually just adding new lines after every key subnode. Cc: Tomasz Maciej Nowak <tomek_n@o2.pl> Cc: Matt Merhar <mattmerhar@protonmail.com> Cc: Jonas Gorski <jonas.gorski@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
* brcm63xx: drop linux,part-probe usage where possibleJonas Gorski2018-07-291-2/+0
| | | | | | | It was present as 4.4 compatibility, but since we now use 4.9 or later with the new upstream solution, we don't need it anymore. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: drop root parameter from cmdlineJonas Gorski2018-02-131-1/+1
| | | | | | | | | | | The root= parameter overrides the automatic rootfs detection by partition name, so drop it. Fixes boot from flash after renumeration changes of partitions due to parser changes. Fixes FS#1350. Fixes: a27d59bb4274 ("brcm63xx: switch to new partition layout specification") Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: switch to new partition layout specificationJonas Gorski2018-02-111-12/+19
| | | | | | | Now that we support parsing the expected upstream definition, update the dts files to it. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: register serial through device treeJonas Gorski2017-12-161-0/+5
| | | | | | | Register serial consoles through device tree instead of through board data. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: probe SPI connected switches through DTJonas Gorski2017-06-101-0/+52
| | | | | | Now that we can configure the switches through DT, do so. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: add pinctrl supportJonas Gorski2017-06-101-8/+13
| | | | | | | Add and enable pincontrol drivers, and update dts(i) files with appropriate hogs. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: move the bootargs into the dtb filesJonas Gorski2016-06-211-0/+4
| | | | | | Instead of using a fixed commandline, allow one per device. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
* brcm63xx: make use of dt-includesJonas Gorski2015-07-161-4/+6
| | | | | | | | | Now that we have a dtc command that invokes the preprocessor, make use of it and replace the magic numbers with KEY_* defines. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46391
* brcm63xx: fix DTS LEDs and buttonsJonas Gorski2015-02-281-1/+1
| | | | | | | | | | | | | - A4001N/A4001N1: fix swapped green and red LEDs - CVG834G: add missing LED - RTA1320: reorder LEDs by GPIO# - V2500V: add missing LEDs and buttons - WAP-5813n: fix WPS button (GPIO 35) Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44577
* brcm63xx: move buttons and leds to dts filesJonas Gorski2015-02-271-0/+50
| | | | | | | | | | | | | | Register buttons and leds through DT for all available dts, and remove them from the board files. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: remove leds/buttons from board files fix wrong led polarities for dsl-274xb-c2, cpva642, p870hw comment out spi-gpio and associated leds] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44566
* brcm63xx: Add DT support for WAP-5813nJonas Gorski2014-08-211-0/+30
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: make linux partition writable] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42243