aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to 'tools')
-rw-r--r--tools/autoconf-archive/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/tools/autoconf-archive/Makefile b/tools/autoconf-archive/Makefile
index 228a27cf60..ecca997313 100644
--- a/tools/autoconf-archive/Makefile
+++ b/tools/autoconf-archive/Makefile
@@ -9,20 +9,8 @@ PKG_HASH:=e8a6eb9d28ddcba8ffef3fa211653239e9bf239aba6a01a6b7cfc7ceaec69cbd
include $(INCLUDE_DIR)/host-build.mk
-HOST_CONFIGURE_ARGS += \
- --datarootdir=$(STAGING_DIR_HOST)/share
-
-define Host/Compile
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
- -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
endef
$(eval $(call HostBuild))