aboutsummaryrefslogtreecommitdiffstats
path: root/tools/squashfs4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/squashfs4/Makefile')
-rw-r--r--tools/squashfs4/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
deleted file mode 100644
index 409b1b5a23..0000000000
--- a/tools/squashfs4/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=squashfs4
-PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
-PKG_VERSION:=4.2
-
-PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/squashfs
-PKG_HASH:=d9e0195aa922dbb665ed322b9aaa96e04a476ee650f39bbeadb0d00b24022e96
-PKG_CAT:=zcat
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfs$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Compile
- +$(HOST_MAKE_VARS) \
- $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
- XZ_SUPPORT=1 \
- LZMA_XZ_SUPPORT=1 \
- XATTR_SUPPORT= \
- LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
- EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
- mksquashfs unsquashfs
-endef
-
-define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
-endef
-
-define Host/Clean
- rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
- rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
-endef
-
-$(eval $(call HostBuild))