aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile20
1 files changed, 4 insertions, 16 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 5ed4107e1d..fd5dad0cd8 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,38 +7,26 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2021.10
+PKG_VERSION:=2022.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=cde723e19262e646f2670d25e5ec4b1b368490de950d4e26275a988c36df0bd4
+PKG_HASH:=81b4543227db228c03f8a1bf5ddbc813b0bb8f6555ce46064ef721a6fc680413
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-define Host/Prepare
- $(Host/Prepare/Default)
- mkdir -p $(HOST_BUILD_DIR)/include/config
- touch $(HOST_BUILD_DIR)/include/config/auto.conf
- mkdir -p $(HOST_BUILD_DIR)/include/generated/
- touch $(HOST_BUILD_DIR)/include/generated/autoconf.h
-endef
-
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTCFLAGS="$(HOST_CFLAGS)" \
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
PKG_CONFIG_EXTRAARGS="--static" \
- no-dot-config-targets=tools-only \
- CONFIG_MKIMAGE_DTC_PATH=dtc \
- CONFIG_FIT=y \
- CONFIG_FIT_SIGNATURE=y \
- CONFIG_FIT_SIGNATURE_MAX_SIZE=0x10000000 \
- CONFIG_TOOLS_LIBCRYPTO=y \
+ V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1) \
+ tools-only_config \
tools-only
endef