aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gnulib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gnulib/Makefile')
-rw-r--r--tools/gnulib/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/gnulib/Makefile b/tools/gnulib/Makefile
new file mode 100644
index 0000000000..c5b7e78c54
--- /dev/null
+++ b/tools/gnulib/Makefile
@@ -0,0 +1,25 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gnulib
+PKG_CPE_ID:=cpe:/a:gnu:$(PKG_NAME)
+PKG_VERSION:=f9a4ee73c3e7b544f640d0d04b55983d3a7b894e# # master
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://git.savannah.gnu.org/cgit/$(PKG_NAME).git/snapshot
+PKG_HASH:=514716d58987a9c0de0d69fb22d42bcd19edf80eed099882a004ff162060f1a8
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(1)/share/gnulib
+ $(CP) $(HOST_BUILD_DIR)/* $(1)/share/gnulib/
+endef
+
+define Host/Clean
+ rm -rf $(STAGING_DIR_HOST)/share/gnulib
+endef
+
+$(eval $(call HostBuild))