aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gengetopt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gengetopt/Makefile')
-rw-r--r--tools/gengetopt/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/gengetopt/Makefile b/tools/gengetopt/Makefile
index 563ecccf9d..5a5b5eb7cb 100644
--- a/tools/gengetopt/Makefile
+++ b/tools/gengetopt/Makefile
@@ -13,12 +13,16 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
PKG_HASH:=b941aec9011864978dd7fdeb052b1943535824169d2aa2b0e7eae9ab807584ac
-HOST_FIXUP:=autoreconf
+PKG_SUBDIRS:=$$$$(foreach dir,gl src skels,$$$$(wildcard $$$$(dir)) )
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+define Host/Compile
+ $(call Host/Compile/Default,SUBDIRS='$(PKG_SUBDIRS)')
+endef
+
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/src/gengetopt $(STAGING_DIR_HOST)/bin/
endef