aboutsummaryrefslogtreecommitdiffstats
path: root/tools/flex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/flex/Makefile')
-rw-r--r--tools/flex/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index da037ae72d..86ba5a4415 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -21,13 +21,17 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
+define Host/Compile
+ $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
define Host/Install
- $(call Host/Install/Default)
+ $(call Host/Compile/Default,install SUBDIRS='src tools')
$(LN) flex $(STAGING_DIR_HOST)/bin/lex
endef
define Host/Uninstall
- -$(call Host/Compile/Default,uninstall)
+ -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
endef
define Host/Clean