aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/110-alpine_musl-compat.patch16
-rw-r--r--tools/cmake/patches/110-libarchive-fix-libressl-compat.patch (renamed from tools/cmake/patches/120-libarchive-fix-libressl-compat.patch)0
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch (renamed from tools/cmake/patches/130-curl-fix-libressl-linking.patch)0
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch (renamed from tools/cmake/patches/140-bootstrap_parallel_make_flag.patch)2
5 files changed, 3 insertions, 19 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 6e8307dea4..46cdc94563 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -284,15 +284,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -407,13 +407,6 @@ if(BUILD_TESTING)
+@@ -422,13 +422,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-alpine_musl-compat.patch b/tools/cmake/patches/110-alpine_musl-compat.patch
deleted file mode 100644
index a2c84fca4a..0000000000
--- a/tools/cmake/patches/110-alpine_musl-compat.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Utilities/cmjsoncpp/include/json/assertions.h
-+++ b/Utilities/cmjsoncpp/include/json/assertions.h
-@@ -6,11 +6,12 @@
- #ifndef CPPTL_JSON_ASSERTIONS_H_INCLUDED
- #define CPPTL_JSON_ASSERTIONS_H_INCLUDED
-
-+#include <stdlib.h>
-+
- #if !defined(JSON_IS_AMALGAMATION)
- #include "config.h"
- #endif // if !defined(JSON_IS_AMALGAMATION)
-
--#include <stdlib.h>
- #include <sstream>
-
- /** It should not be possible for a maliciously designed file to
diff --git a/tools/cmake/patches/120-libarchive-fix-libressl-compat.patch b/tools/cmake/patches/110-libarchive-fix-libressl-compat.patch
index ba6565b6af..ba6565b6af 100644
--- a/tools/cmake/patches/120-libarchive-fix-libressl-compat.patch
+++ b/tools/cmake/patches/110-libarchive-fix-libressl-compat.patch
diff --git a/tools/cmake/patches/130-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index ad5b89750e..ad5b89750e 100644
--- a/tools/cmake/patches/130-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
diff --git a/tools/cmake/patches/140-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index a3cdefbb16..de5137ee38 100644
--- a/tools/cmake/patches/140-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1130,7 +1130,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1149,7 +1149,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then