aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison/Makefile')
-rw-r--r--tools/bison/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 5f96463ae0..30555541e6 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -19,14 +19,14 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --enable-threads=posix --disable-nls
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
-endef
-
define Host/Install
$(call Host/Install/Default)
$(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
endef
+define Host/Uninstall
+ rm -f $(STAGING_DIR_HOST)/bin/yacc
+ -$(call Host/Compile/Default,uninstall)
+endef
+
$(eval $(call HostBuild))