aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile7
-rw-r--r--toolchain/binutils/Makefile6
-rw-r--r--toolchain/gdb/Makefile6
-rw-r--r--toolchain/ipkg-utils/Makefile6
-rw-r--r--toolchain/jffs2/Makefile6
-rw-r--r--toolchain/kernel-headers/Makefile6
-rw-r--r--toolchain/libnotimpl/Makefile6
-rw-r--r--toolchain/lzma/Makefile6
-rw-r--r--toolchain/sed/Makefile6
-rw-r--r--toolchain/squashfs/Makefile6
-rw-r--r--toolchain/sstrip/Makefile6
-rw-r--r--toolchain/uClibc/Makefile6
-rw-r--r--toolchain/uClibc/config/i3867
-rw-r--r--toolchain/uClibc/config/mips7
-rw-r--r--toolchain/uClibc/config/mipsel7
-rw-r--r--toolchain/uClibc/config/powerpc7
16 files changed, 101 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 6481ed0d10..043a119b15 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -1,4 +1,11 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
# Main makefile for the toolchain
+#
include $(TOPDIR)/rules.mk
TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
TARGETS-$(CONFIG_GDB) += gdb
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 6d4f96f914..a5b905eb52 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 538ef51207..f5c0bf3725 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
diff --git a/toolchain/ipkg-utils/Makefile b/toolchain/ipkg-utils/Makefile
index 5d324f728a..4520af176e 100644
--- a/toolchain/ipkg-utils/Makefile
+++ b/toolchain/ipkg-utils/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME := ipkg-utils
diff --git a/toolchain/jffs2/Makefile b/toolchain/jffs2/Makefile
index 02364020a4..93e2589c20 100644
--- a/toolchain/jffs2/Makefile
+++ b/toolchain/jffs2/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME:=mtd
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index 9d2f32e863..7e08508b63 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME=kernel-headers
diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
index aae7aef34a..bc515ca080 100644
--- a/toolchain/libnotimpl/Makefile
+++ b/toolchain/libnotimpl/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME := libnotimpl
diff --git a/toolchain/lzma/Makefile b/toolchain/lzma/Makefile
index 6488a06280..ab8fea0e6a 100644
--- a/toolchain/lzma/Makefile
+++ b/toolchain/lzma/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME := lzma
diff --git a/toolchain/sed/Makefile b/toolchain/sed/Makefile
index 0832ede280..fdeeeea2ab 100644
--- a/toolchain/sed/Makefile
+++ b/toolchain/sed/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME := sed
diff --git a/toolchain/squashfs/Makefile b/toolchain/squashfs/Makefile
index 7b3eed5d60..ac5edd9967 100644
--- a/toolchain/squashfs/Makefile
+++ b/toolchain/squashfs/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
PKG_NAME := squashfs
diff --git a/toolchain/sstrip/Makefile b/toolchain/sstrip/Makefile
index aa18e21c5f..49983e9129 100644
--- a/toolchain/sstrip/Makefile
+++ b/toolchain/sstrip/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/host-build.mk
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 1499573ced..bb52ee300f 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
diff --git a/toolchain/uClibc/config/i386 b/toolchain/uClibc/config/i386
index b1a9ec3a1c..e787c580d4 100644
--- a/toolchain/uClibc/config/i386
+++ b/toolchain/uClibc/config/i386
@@ -1,3 +1,10 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
#
# Automatically generated make config: don't edit
#
diff --git a/toolchain/uClibc/config/mips b/toolchain/uClibc/config/mips
index 06c3d829b6..3f1f3a7f6a 100644
--- a/toolchain/uClibc/config/mips
+++ b/toolchain/uClibc/config/mips
@@ -1,3 +1,10 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
#
# Automatically generated make config: don't edit
#
diff --git a/toolchain/uClibc/config/mipsel b/toolchain/uClibc/config/mipsel
index 8a7db1a3dc..acdb2aa273 100644
--- a/toolchain/uClibc/config/mipsel
+++ b/toolchain/uClibc/config/mipsel
@@ -1,3 +1,10 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
#
# Automatically generated make config: don't edit
#
diff --git a/toolchain/uClibc/config/powerpc b/toolchain/uClibc/config/powerpc
index 457c7d5e53..de1ffaab15 100644
--- a/toolchain/uClibc/config/powerpc
+++ b/toolchain/uClibc/config/powerpc
@@ -1,4 +1,11 @@
+#
+# Copyright (C) 2006 OpenWrt.org
#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+#
+
# Automatically generated make config: don't edit
#
# TARGET_alpha is not set