aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/insight
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/insight')
-rw-r--r--toolchain/insight/Makefile51
-rw-r--r--toolchain/insight/patches/600-fix-compile-flag-mismatch.patch31
2 files changed, 0 insertions, 82 deletions
diff --git a/toolchain/insight/Makefile b/toolchain/insight/Makefile
deleted file mode 100644
index 63a0e27ced..0000000000
--- a/toolchain/insight/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=insight
-PKG_VERSION:=6.8-1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
-PKG_HASH:=51216df73adc4f68c67b60356270d5073f0ff094c1b477ecd96560f49707ea2a
-PKG_SOURCE_URL:=ftp://sourceware.org/pub/insight/releases
-PKG_CAT:=bzcat
-
-include $(INCLUDE_DIR)/toolchain-build.mk
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- gdb_cv_func_sigsetjmp=yes \
- CFLAGS="-O2" \
- $(HOST_BUILD_DIR)/configure \
- --prefix=$(TOOLCHAIN_DIR) \
- --build=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
- --enable-threads \
- --enable-werror=no \
- );
-endef
-
-define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
- mkdir -p $(TOOLCHAIN_DIR)/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/insight $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight
- ln -fs $(TARGET_CROSS)insight $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-insight
- strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight
-endef
-
-define Host/Clean
- rm -rf \
- $(HOST_BUILD_DIR) \
- $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight \
- $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-insight
-endef
-
-$(eval $(call HostBuild))
diff --git a/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch b/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch
deleted file mode 100644
index 13b72bb96d..0000000000
--- a/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -1239,7 +1239,7 @@
- ac_cache_corrupted=: ;;
- ,);;
- *)
-- if test "x$ac_old_val" != "x$ac_new_val"; then
-+ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
- { echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
- echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
- { echo "$as_me:$LINENO: former value: $ac_old_val" >&5
---- a/gdb/configure
-+++ b/gdb/configure
-@@ -272,7 +272,7 @@
- PACKAGE_BUGREPORT=
-
- ac_unique_file="main.c"
--ac_subdirs_all="$ac_subdirs_all doc testsuite"
-+ac_subdirs_all="$ac_subdirs_all doc"
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
-@@ -3077,7 +3077,7 @@
-
-
-
--subdirs="$subdirs doc testsuite"
-+subdirs="$subdirs doc"
-
-
- # Provide defaults for some variables set by the per-host and per-target