aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 6e8767f707..6e0edfb36a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -170,6 +170,11 @@ ifeq ($(CONFIG_arm),y)
--with-fpu=$(word 2, $(subst +, ",$(CONFIG_CPU_TYPE))) \
--with-float=hard
endif
+
+ # Do not let TARGET_CFLAGS get poisoned by extra CPU optimization flags
+ # that do not belong here. The cpu,fpu type should be specified via
+ # --with-cpu and --with-fpu for ARM and not CFLAGS.
+ TARGET_CFLAGS:=$(filter-out -m%,$(call qstrip,$(TARGET_CFLAGS)))
endif
ifeq ($(CONFIG_TARGET_x86)$(CONFIG_USE_GLIBC)$(CONFIG_INSTALL_GCCGO),yyy)