aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in7
-rw-r--r--toolchain/gcc/common.mk6
2 files changed, 2 insertions, 11 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 41ea61cb8a..34c597c9e0 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -23,15 +23,10 @@ choice
endchoice
config GCC_USE_GRAPHITE
+ depends on !GCC_VERSION_4_8_ARC
bool
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
-config GCC_USE_SYSTEM_PPL_CLOOG
- bool
- prompt "Use the system versions of PPL and CLooG"
- depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
- default n
-
config EXTRA_GCC_CONFIG_OPTIONS
string
prompt "Additional gcc configure options" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 37c228e4a6..c1010dd0c9 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -80,11 +80,7 @@ ifdef CONFIG_INSTALL_GCCGO
endif
ifdef CONFIG_GCC_USE_GRAPHITE
- ifdef CONFIG_GCC_VERSION_4_8
- GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
- else
- GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
- endif
+ GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
else
GRAPHITE_CONFIGURE=--without-isl --without-cloog
endif